summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJannis Mattheis2020-03-04 18:30:24 +0100
committerJannis Mattheis2020-03-04 18:30:24 +0100
commit4d4251e57e10580dcb0883b4a3cc11cacc45d56b (patch)
treed1e52cd2b362d5c6e8556bc1a1870ecebf25e56c
downloadaur-gruvbox-dark-icons-gtk.tar.gz
Initial Commit
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD22
3 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..df052cae545c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = gruvbox-dark-icons-gtk
+ pkgdesc = Gruvbox dark icon theme
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = https://github.com/jmattheis/gruvbox-dark-icons-gtk
+ arch = any
+ license = GPL3
+ optdepends = gruvbox-dark-gtk: matching gtk theme.
+ options = !strip
+ source = gruvbox-dark-icons-gtk-1.0.0.tar.gz::https://github.com/jmattheis/gruvbox-dark-icons-gtk/archive/v1.0.0.tar.gz
+ sha256sums = 777d1defdb7a6d9977e1cf417dfbe297b5861bc81ceaa7772cef4fff1362813d
+
+pkgname = gruvbox-dark-icons-gtk
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..ae8de978151e
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+*.tar.*
+src
+pkg
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1454ebc022cd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: jmattheis <contact AT jmattheis DOT de>
+pkgname=gruvbox-dark-icons-gtk
+pkgver=1.0.0
+pkgrel=1
+options=(!strip)
+pkgdesc='Gruvbox dark icon theme'
+optdepends=('gruvbox-dark-gtk: matching gtk theme.')
+arch=('any')
+url="https://github.com/jmattheis/gruvbox-dark-icons-gtk"
+license=('GPL3')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/jmattheis/gruvbox-dark-icons-gtk/archive/v$pkgver.tar.gz")
+sha256sums=('777d1defdb7a6d9977e1cf417dfbe297b5861bc81ceaa7772cef4fff1362813d')
+
+package() {
+ mkdir -p "$pkgdir/usr/share/icons/$pkgname"
+ cd "$srcdir/$pkgname-$pkgver"
+ rm README.md
+ cp -r * "$pkgdir/usr/share/icons/$pkgname"
+ chown -R root:root "$pkgdir/usr/share/icons"
+ chmod -R ugo+rX "$pkgdir/usr/share/icons"
+}
+