summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavide Depau2018-06-17 16:02:18 +0200
committerDavide Depau2018-06-17 16:02:18 +0200
commitb1b8db3e8b7afba4d5eb1ad1cfb6f29a55720887 (patch)
tree1088a8b0e8d39c81dfe707feb155a0c50dcfb665
parente6167fd07822e6448bc5f1eed8c88b49892a64f2 (diff)
downloadaur-gst-plugin-viperfx-git.tar.gz
Add patch to update plugin source and set it to AUR
-rw-r--r--.SRCINFO4
-rw-r--r--0002-Update-plugin-source-and-set-it-to-AUR.patch25
-rw-r--r--PKGBUILD7
3 files changed, 33 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d896945b58d2..d5f3ba89c1aa 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = gst-plugin-viperfx-git
pkgdesc = ViPER FX core wrapper plugin for GStreamer1
pkgver = r2.227da1f
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/vipersaudio/gst-plugin-viperfx
arch = x86_64
license = custom
@@ -11,8 +11,10 @@ pkgbase = gst-plugin-viperfx-git
conflicts = gst-plugin-viperfx
source = gst-plugin-viperfx-git::git+https://github.com/vipersaudio/gst-plugin-viperfx.git
source = 0001-Set-license-to-a-gst-supported-one.patch
+ source = 0002-Update-plugin-source-and-set-it-to-AUR.patch
sha256sums = SKIP
sha256sums = 3f56f4b2bea7af80309b0ea668877d6fb028677aab966eb946ba4463dd118eea
+ sha256sums = c618b22ddb9e2a277efd88c4e46f05d1cd8af7d77a92b6da7bcfa7a923ad8b15
pkgname = gst-plugin-viperfx-git
diff --git a/0002-Update-plugin-source-and-set-it-to-AUR.patch b/0002-Update-plugin-source-and-set-it-to-AUR.patch
new file mode 100644
index 000000000000..fedbdd58ea6e
--- /dev/null
+++ b/0002-Update-plugin-source-and-set-it-to-AUR.patch
@@ -0,0 +1,25 @@
+From 8ee243ddfd44f699772cf803978a0b5f6775f5e2 Mon Sep 17 00:00:00 2001
+From: Davide Depau <davide@depau.eu>
+Date: Sun, 17 Jun 2018 15:58:55 +0200
+Subject: [PATCH] Update plugin source and set it to AUR
+
+---
+ src/gstviperfx.c | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/src/gstviperfx.c b/src/gstviperfx.c
+index 3120e77..1a395b5 100644
+--- a/src/gstviperfx.c
++++ b/src/gstviperfx.c
+@@ -1559,6 +1559,6 @@ GST_PLUGIN_DEFINE (
+ viperfx_init,
+ VERSION,
+ "Proprietary",
+- "GStreamer",
+- "http://gstreamer.net/"
++ "GStreamer ViPER FX Plugin (Arch User Repository)",
++ "https://aur.archlinux.org/packages/gst-plugin-viperfx-git/"
+ )
+--
+2.17.1
+
diff --git a/PKGBUILD b/PKGBUILD
index e249e554cdb6..1b66e9878c6d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=gst-plugin-viperfx-git
pkgver=r2.227da1f
-pkgrel=1
+pkgrel=2
pkgdesc="ViPER FX core wrapper plugin for GStreamer1"
url="https://github.com/vipersaudio/gst-plugin-viperfx"
arch=("x86_64")
@@ -13,9 +13,11 @@ depends=("libviperfx" "gstreamer")
source=(
"$pkgname::git+https://github.com/vipersaudio/gst-plugin-viperfx.git"
"0001-Set-license-to-a-gst-supported-one.patch"
+ "0002-Update-plugin-source-and-set-it-to-AUR.patch"
)
sha256sums=('SKIP'
- '3f56f4b2bea7af80309b0ea668877d6fb028677aab966eb946ba4463dd118eea')
+ '3f56f4b2bea7af80309b0ea668877d6fb028677aab966eb946ba4463dd118eea'
+ 'c618b22ddb9e2a277efd88c4e46f05d1cd8af7d77a92b6da7bcfa7a923ad8b15')
pkgver() {
cd "$srcdir/$pkgname"
@@ -28,6 +30,7 @@ pkgver() {
prepare() {
cd "$srcdir/$pkgname"
patch -p1 < $srcdir/0001-Set-license-to-a-gst-supported-one.patch
+ patch -p1 < $srcdir/0002-Update-plugin-source-and-set-it-to-AUR.patch
}
build() {