summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatrix2022-05-20 19:21:50 +0100
committerMatrix2022-05-20 19:21:50 +0100
commit2eefaca7fb5186f99f44f86db409a73777d3bc4a (patch)
treed791b1300c64b16dd585f358bb626550ca4250b9
parentd45fc2276b790e685494dc3bc93913f65cc736da (diff)
downloadaur-gstreamer0.10.tar.gz
Fixed issues and added python3 as make dependancy
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD6
2 files changed, 6 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8b44e8e53108..fe69d2c30b9d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,7 @@
-# Generated by mksrcinfo v8
-# Wed Oct 4 04:49:47 UTC 2017
pkgbase = gstreamer0.10
pkgdesc = GStreamer Multimedia Framework
pkgver = 0.10.36
- pkgrel = 17
+ pkgrel = 20
url = https://gstreamer.freedesktop.org
arch = i686
arch = x86_64
@@ -11,6 +9,7 @@ pkgbase = gstreamer0.10
license = LGPL
makedepends = intltool
makedepends = gobject-introspection
+ makedepends = python3
depends = libxml2
depends = glib2
source = https://gstreamer.freedesktop.org/src/gstreamer/gstreamer-0.10.36.tar.xz
@@ -21,4 +20,3 @@ pkgbase = gstreamer0.10
sha256sums = ed154e280abf59b24d98a8ab0fe868b449b26aa61f7ae3813fab8ac615fcaefa
pkgname = gstreamer0.10
-
diff --git a/PKGBUILD b/PKGBUILD
index c66cc3a7de69..badbc42b738f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,18 @@
# Contributor: Yurii Kolesnykov <yurikoles@gmail.com>
# Contributor: Jan de Groot <jgc@archlinux.org>
# Maintainer: ava1ar <mail(at)ava1ar(dot)me>
+# Maintainer: Matrix <thysupremematrix at tuta dot io>
pkgname=gstreamer0.10
_pkgname=gstreamer
pkgver=0.10.36
-pkgrel=17
+pkgrel=20
pkgdesc="GStreamer Multimedia Framework"
arch=('i686' 'x86_64' 'armv7h')
license=('LGPL')
url='https://gstreamer.freedesktop.org'
depends=('libxml2' 'glib2')
-makedepends=('intltool' 'gobject-introspection')
+makedepends=('intltool' 'gobject-introspection' 'python3')
source=("https://gstreamer.freedesktop.org/src/gstreamer/${_pkgname}-${pkgver}.tar.xz"
'tests-remove-silly-test_fail_abstract_new-check.patch'
'bison3.patch')
@@ -24,6 +25,7 @@ prepare() {
patch -Np1 -i ../tests-remove-silly-test_fail_abstract_new-check.patch
patch -Np1 -i ../bison3.patch
sed -e 's/AM_CONFIG_HEADER/AC_CONFIG_HEADERS/' -i configure.ac
+ sed -e 's/static volatile gsize gonce_data/static gsize gonce_data/g' -i gst/gstutils.h
}
build() {