summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorshtrom2014-04-03 06:17:19 +0000
committershtrom2014-04-03 06:17:19 +0000
commit8a4cbd22c00340692932a3968a5c74c6aa15829a (patch)
treea8c3216479afc67d61a202847551c9fbaf853b7f
parent5f287ffe7c69bed5ffd9ba4ca7f043073384f213 (diff)
downloadaur-8a4cbd22c00340692932a3968a5c74c6aa15829a.tar.gz
[gtg-git] Building from git.
git-svn-id: svn+ssh://scm.narf.ssji.net/svn/archlinux-packages@360 df209809-8e4a-0410-9a64-c169741eb0fc
-rw-r--r--.SRCINFO31
-rw-r--r--PKGBUILD65
-rw-r--r--gtg-git.install (renamed from gtg-bzr.install)2
3 files changed, 70 insertions, 28 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 715dbea36b13..d28f54b75d96 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
-pkgbase = gtg-bzr
- pkgdesc = Personal GTD like organizer for the GNOME desktop environment. bzr version.
- pkgver = 1234
+pkgbase = gtg-git
+ pkgdesc = Personal GTD like organizer for the GNOME desktop environment. Git version.
+ pkgver = 1
pkgrel = 1
- url = http://gtg.fritalk.com/
- install = gtg-bzr.install
+ url = http://gtgnome.net/
+ install = gtg-git.install
arch = i686
arch = x86_64
license = GPL
@@ -17,8 +17,25 @@ pkgbase = gtg-bzr
depends = hicolor-icon-theme
depends = desktop-file-utils
depends = python2-gnomekeyring
- depends = python2-liblarch-git
+ depends = python-liblarch-git
+ optdepends = python-bugz: for Bugzilla plugin
+ optdepends = python-cheetah: for Export and print plugin
+ optdepends = pdflatex: for Export and print plugin
+ optdepends = pdftk: for Export and print plugin
+ optdepends = pdfjam: for Export and print plugin
+ optdepends = python-geoclue: for Geolocalized tasks plugin
+ optdepends = python-clutter: for Geolocalized tasks plugin
+ optdepends = python-clutter-gtk: for Geolocalized tasks plugin
+ optdepends = python-champlain: for Geolocalized tasks plugin
+ optdepends = python-champlain-gtk: for Geolocalized tasks plugin
+ optdepends = hamster-time-tracker: for Hamster Time Tracker Integration to integrate with
+ optdepends = python-appindicator: for Notification area plugin
+ optdepends = python-dbus: for Tomboy/Gnote plugin
+ optdepends = python-evolution: for Evolution synchronization service
+ optdepends = python-dateutil: for Evolution and RememberTheMilk synchronization services
+ optdepends = python-suds: for MantisBT synchronization service
+ optdepends = python-launchpadlib: for Launchpad synchronization service
conflicts = gtg
-pkgname = gtg-bzr
+pkgname = gtg-git
diff --git a/PKGBUILD b/PKGBUILD
index 3030bb638fac..dc6bea7c326a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,43 +1,68 @@
# Contributor: Baptiste Grenier <baptiste@bapt.name>
-# Maintainer: Pablo Olmos de Aguilera Corradini <pablo <at] glatelier (dot} org>
-pkgname=gtg-bzr
-pkgver=1234
+# Contributor: Pablo Olmos de Aguilera Corradini <pablo <at] glatelier (dot} org>
+# Maintainer: Olivier Mehani <shtrom-aur@ssji.net>
+pkgname=gtg-git
+pkgver=1
pkgrel=1
-pkgdesc="Personal GTD like organizer for the GNOME desktop environment. bzr version."
-url="http://gtg.fritalk.com/"
+pkgdesc="Personal GTD like organizer for the GNOME desktop environment. Git version."
+url="http://gtgnome.net/"
arch=('i686' 'x86_64')
license=('GPL')
depends=('pygtk' 'pygobject' 'python2-configobj' 'pyxdg' 'dbus-python'
'hicolor-icon-theme' 'desktop-file-utils' 'python2-gnomekeyring'
-'python2-liblarch-git')
+'python-liblarch-git')
makedepends=('bzr' 'python2-gconf')
+optdepends=(
+"python-bugz: for Bugzilla plugin"
+"python-cheetah: for Export and print plugin"
+"pdflatex: for Export and print plugin"
+"pdftk: for Export and print plugin"
+"pdfjam: for Export and print plugin"
+"python-geoclue: for Geolocalized tasks plugin"
+"python-clutter: for Geolocalized tasks plugin"
+"python-clutter-gtk: for Geolocalized tasks plugin"
+"python-champlain: for Geolocalized tasks plugin"
+"python-champlain-gtk: for Geolocalized tasks plugin"
+"hamster-time-tracker: for Hamster Time Tracker Integration to integrate with"
+"python-appindicator: for Notification area plugin"
+"python-dbus: for Tomboy/Gnote plugin"
+"python-evolution: for Evolution synchronization service"
+"python-dateutil: for Evolution and RememberTheMilk synchronization services"
+"python-suds: for MantisBT synchronization service"
+"python-launchpadlib: for Launchpad synchronization service"
+)
conflicts=('gtg')
-install="gtg-bzr.install"
+install="${pkgname}.install"
source=()
md5sums=()
-_bzrtrunk=lp:gtg
-_bzrmod=trunk
+_gitroot=https://github.com/getting-things-gnome/gtg
+_gitname=${pkgname}
-build() {
- cd ${srcdir}
+prepare() {
+ cd "${srcdir}"
+ msg "Connecting to GIT server...."
- msg "Connecting to the server...."
- if [ ! -d ./${_bzrmod} ]; then
- bzr co ${_bzrtrunk} ${_bzrmod} -r ${pkgver}
+ if [[ -d "${_gitname}" ]]; then
+ cd "${_gitname}" && git pull origin
+ msg "The local files are updated."
else
- bzr up ${_bzrmod}
+ git clone "${_gitroot}" "${_gitname}"
fi
- msg "BZR checkout done or server timeout"
- msg "Starting packaging..."
+ msg "GIT checkout done or server timeout"
+ msg "Starting build..."
- cd ${srcdir}/${_bzrmod}
- python2 setup.py install --root=${pkgdir}
+ rm -rf "${srcdir}/${_gitname}-build"
+ git clone "${srcdir}/${_gitname}" "${srcdir}/${_gitname}-build"
+ cd "${srcdir}/${_gitname}-build"
+
+ python setup.py build
}
package() {
- return 0
+ cd "${srcdir}/${_gitname}"
+ python setup.py install --root=${pkgdir}
}
# vim:set ts=2 sw=2 et:
diff --git a/gtg-bzr.install b/gtg-git.install
index 49df145db16b..c8b946fac68d 100644
--- a/gtg-bzr.install
+++ b/gtg-git.install
@@ -1,4 +1,4 @@
-pkgname=gtg-bzr
+pkgname=gtg-git
post_install() {
gtk-update-icon-cache -q -t -f usr/share/icons/hicolor