summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorandrewSC2020-11-09 09:57:19 -0500
committerandrewSC2020-11-09 09:57:19 -0500
commit042f1417bbb74859b13ee9ccb361881bb816e03a (patch)
treea77ce15376e0c2c09e9cb61e9f2ba6fefb3d2445
parenteda97284da4b33181af0d41fcbf9e261c8501b07 (diff)
downloadaur-042f1417bbb74859b13ee9ccb361881bb816e03a.tar.gz
moving wayland to makedeps, config wayland backend to be built
-rw-r--r--.SRCINFO9
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD17
3 files changed, 18 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1d845dd2ede8..b61992263dc5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = gtk4-git
pkgdesc = GObject-based multi-platform GUI toolkit (GIT Version)
- pkgver = 3.94.0.r400.g0edec9bcae
+ pkgver = 3.99.4.r42.g53cd499621
pkgrel = 1
url = https://www.gtk.org/
arch = x86_64
@@ -11,6 +11,8 @@ pkgbase = gtk4-git
makedepends = meson
makedepends = ninja
makedepends = vulkan-headers
+ makedepends = wayland
+ makedepends = wayland-protocols
depends = at-spi2-atk
depends = cairo
depends = atk
@@ -24,11 +26,10 @@ pkgbase = gtk4-git
depends = libxrandr
depends = mesa
depends = pango
- depends = wayland
depends = graphene
depends = json-glib
+ depends = shared-mime-info
depends = gdk-pixbuf2
- depends = wayland-protocols
depends = colord
depends = libcups
depends = rest
@@ -38,6 +39,8 @@ pkgbase = gtk4-git
optdepends = gnome-themes-standard: Default widget theme
optdepends = hicolor-icon-theme: Freedesktop.org Hicolor icon theme
optdepends = gdk-pixbuf2: An image loading library
+ optdepends = wayland: A computer display server protocol
+ optdepends = wayland-protocols: Specifications of extended Wayland protocols
source = git+https://gitlab.gnome.org/GNOME/gtk.git
source = gtk4.install
source = gtk4-query-immodules.hook
diff --git a/.gitignore b/.gitignore
index c056f0fd248f..8499506bf37f 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,6 +1,8 @@
gtk/
pkg/
src/
+logs/
+*.zst
*.tar
*.log
*.xz
diff --git a/PKGBUILD b/PKGBUILD
index ffadbdae105d..7ea24cc3d50e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Andrew Crerar <andrew (at) crerar (dot) io>
pkgname=(gtk4-git)
-pkgver=3.94.0.r400.g0edec9bcae
+pkgver=3.99.4.r42.g53cd499621
pkgrel=1
pkgdesc="GObject-based multi-platform GUI toolkit (GIT Version)"
arch=('x86_64')
@@ -9,14 +9,16 @@ url="https://www.gtk.org/"
license=('LGPL')
depends=('at-spi2-atk' 'cairo' 'atk' 'dconf' 'glib2' 'libepoxy'
'libxcomposite' 'libxcursor' 'libxinerama' 'libxkbcommon' 'libxrandr' 'mesa'
- 'pango' 'wayland' 'graphene' 'json-glib'
- 'gdk-pixbuf2' 'wayland-protocols'
- 'colord' 'libcups' 'rest' 'vulkan-icd-loader' 'gst-plugins-bad')
-makedepends=('gobject-introspection' 'gtk-doc' 'git' 'meson' 'ninja' 'vulkan-headers')
+ 'pango' 'graphene' 'json-glib' 'shared-mime-info' 'gdk-pixbuf2' 'colord'
+ 'libcups' 'rest' 'vulkan-icd-loader' 'gst-plugins-bad')
+makedepends=('gobject-introspection' 'gtk-doc' 'git' 'meson' 'ninja' 'vulkan-headers'
+ 'wayland' 'wayland-protocols')
optdepends=('gnome-icon-theme: Default icon theme'
'gnome-themes-standard: Default widget theme'
'hicolor-icon-theme: Freedesktop.org Hicolor icon theme'
- 'gdk-pixbuf2: An image loading library')
+ 'gdk-pixbuf2: An image loading library'
+ 'wayland: A computer display server protocol'
+ 'wayland-protocols: Specifications of extended Wayland protocols')
source=('git+https://gitlab.gnome.org/GNOME/gtk.git'
'gtk4.install'
'gtk4-query-immodules.hook'
@@ -45,7 +47,8 @@ build() {
--localstatedir=/var \
--libdir=lib \
-Dbroadway-backend=true \
- -Dvulkan=yes \
+ -Dvulkan=enabled \
+ -Dwayland-backend=true \
_build .
cd _build