summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrew Crerar2017-12-04 20:29:34 -0500
committerAndrew Crerar2017-12-04 20:29:34 -0500
commit106ce1f017d5044d68fe30c0d0d71b9d856eab4f (patch)
tree82fbebf16c1585937a4fa27d2a9ce0982cc04422
parent341e5a6118ee277c49d103f06c7ead165e04c2cc (diff)
downloadaur-106ce1f017d5044d68fe30c0d0d71b9d856eab4f.tar.gz
Adding vulkan support
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD5
2 files changed, 5 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ecec7dc685bf..2ab32d51806e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = gtk4-git
pkgdesc = GObject-based multi-platform GUI toolkit (GIT Version)
- pkgver = 3.93.0.r579.ga687fd9aeb
+ pkgver = 3.93.0.r863.g6f00c1b626
pkgrel = 1
url = https://www.gtk.org/
arch = x86_64
@@ -28,6 +28,7 @@ pkgbase = gtk4-git
depends = colord
depends = libcups
depends = rest
+ depends = vulkan-icd-loader
optdepends = gnome-icon-theme: Default icon theme
optdepends = gnome-themes-standard: Default widget theme
optdepends = hicolor-icon-theme: Freedesktop.org Hicolor icon theme
diff --git a/PKGBUILD b/PKGBUILD
index d9e49a805c40..f0bd450298b6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Andrew Crerar <andrew (at) crerar (dot) io>
pkgname=(gtk4-git)
-pkgver=3.93.0.r579.ga687fd9aeb
+pkgver=3.93.0.r863.g6f00c1b626
pkgrel=1
pkgdesc="GObject-based multi-platform GUI toolkit (GIT Version)"
arch=('x86_64')
@@ -10,7 +10,7 @@ license=('LGPL')
depends=('at-spi2-atk' 'atk-git>=2.15.1' 'dconf' 'glib2-git>=2.53.7' 'libepoxy>=1.4'
'libxcomposite' 'libxcursor' 'libxinerama' 'libxkbcommon' 'libxrandr' 'mesa'
'pango-git>=1.37.3' 'wayland-git>=1.9.91' 'graphene>=1.5.1' 'json-glib'
- 'colord' 'libcups' 'rest')
+ 'colord' 'libcups' 'rest' 'vulkan-icd-loader')
makedepends=('gobject-introspection-git' 'gtk-doc' 'git' 'meson' 'ninja')
optdepends=('gnome-icon-theme: Default icon theme'
'gnome-themes-standard: Default widget theme'
@@ -44,6 +44,7 @@ build() {
--localstatedir=/var \
--libdir=/usr/lib \
-Denable-broadway-backend=true \
+ -Denable-vulkan=yes \
_build .
cd _build