summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarsten Teibes2017-01-05 16:07:11 +0100
committerCarsten Teibes2017-01-05 16:07:11 +0100
commit3b751decebd9ec0e076c9f39360290e98a608463 (patch)
tree1afac1f6f35aaefec957f24436f0f9c9342d81e6
parent9856c3dd73a6a0b653c99011026fdc90fb18c13e (diff)
downloadaur-3b751decebd9ec0e076c9f39360290e98a608463.tar.gz
[upd] 0.7.0→1.0
Add Caja extension Use alpm hook instead of .install file
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD42
-rw-r--r--gtkhash.desktop8
-rw-r--r--gtkhash.install12
4 files changed, 37 insertions, 43 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b255eae46160..416a1772101c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,26 +1,25 @@
pkgbase = gtkhash
pkgdesc = A GTK+ utility for computing message digests or checksums
- pkgver = 0.7.0
- pkgrel = 3
+ pkgver = 1.0
+ pkgrel = 1
url = http://gtkhash.sourceforge.net/
arch = i686
arch = x86_64
arch = mips64el
license = GPL
makedepends = intltool
+ makedepends = librsvg
makedepends = nemo
makedepends = libnautilus-extension
makedepends = thunar
+ makedepends = caja-gtk3
depends = dconf
depends = nettle
depends = gtk3
- source = http://downloads.sourceforge.net/gtkhash/gtkhash-0.7.0.tar.xz
- source = gtkhash.desktop
- sha256sums = 161d4f27f2d412c8cb3f566ca3aa8144942bbf836c18bcb1e5f79451e6f5dfdd
- sha256sums = f0312086093f0dd5ce0cfd6c9312abd42b57401960c39c19377372c154a32388
+ source = http://downloads.sourceforge.net/gtkhash/gtkhash-1.0.tar.xz
+ sha256sums = ae1faac88a745953bba583c91173d08f8aab8153c30418b10ed43496ea561e45
pkgname = gtkhash
- install = gtkhash.install
pkgname = gtkhash-nemo
pkgdesc = A GTK+ utility for computing message digests or checksums (Nemo filemanager plugin)
@@ -37,3 +36,8 @@ pkgname = gtkhash-thunar
depends = gtkhash
depends = thunar
+pkgname = gtkhash-caja
+ pkgdesc = A GTK+ utility for computing message digests or checksums (Caja filemanager plugin)
+ depends = gtkhash
+ depends = caja-gtk3
+
diff --git a/PKGBUILD b/PKGBUILD
index 85bb0a7c4e53..efa8496bb6e7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,38 +1,33 @@
-# Maintainer: carstene1ns <url/mail: arch carsten-teibes de>
+# Maintainer: carstene1ns <arch carsten-teibes de> - http://git.io/ctPKG
# Contributor: Jan Böhringer <janboe@gmail.com>
# Contributor: Frédérik Paradis <fredy_14@live.fr>
# Contributor: GI_Jack <GI_Jack@hushmail.com>
pkgbase=gtkhash
-pkgname=(gtkhash gtkhash-nemo gtkhash-nautilus gtkhash-thunar)
-pkgver=0.7.0
-pkgrel=3
+pkgname=(gtkhash gtkhash-nemo gtkhash-nautilus gtkhash-thunar gtkhash-caja)
+pkgver=1.0
+pkgrel=1
pkgdesc="A GTK+ utility for computing message digests or checksums"
arch=('i686' 'x86_64' 'mips64el')
url="http://gtkhash.sourceforge.net/"
license=('GPL')
-makedepends=('intltool' 'nemo' 'libnautilus-extension' 'thunar') # ← remove FMs here!
+makedepends=('intltool' 'librsvg' 'nemo' 'libnautilus-extension' 'thunar' 'caja-gtk3') # ← remove FMs here!
depends=('dconf' 'nettle' 'gtk3')
-source=("http://downloads.sourceforge.net/gtkhash/gtkhash-$pkgver.tar.xz"
- "gtkhash.desktop")
-sha256sums=('161d4f27f2d412c8cb3f566ca3aa8144942bbf836c18bcb1e5f79451e6f5dfdd'
- 'f0312086093f0dd5ce0cfd6c9312abd42b57401960c39c19377372c154a32388')
+source=("http://downloads.sourceforge.net/gtkhash/gtkhash-$pkgver.tar.xz")
+sha256sums=('ae1faac88a745953bba583c91173d08f8aab8153c30418b10ed43496ea561e45')
build() {
cd gtkhash-$pkgver
./configure --prefix=/usr --disable-schemas-compile --enable-gtkhash \
--enable-linux-crypto --enable-nettle --with-gtk=3.0 \
- --enable-nemo --enable-nautilus --enable-thunar # ← remove FMs here!
+ --enable-nemo --enable-nautilus --enable-thunar --enable-caja # ← remove FMs here!
make
}
package_gtkhash() {
- install=gtkhash.install
-
make -C gtkhash-$pkgver DESTDIR="$pkgdir/" install
- # install desktop entry
- install -Dm644 gtkhash.desktop "$pkgdir"/usr/share/applications/gtkhash.desktop
+
# remove filemanager plugins
rm -rf "$pkgdir"/usr/lib
}
@@ -41,7 +36,9 @@ package_gtkhash-nemo() {
pkgdesc+=' (Nemo filemanager plugin)'
depends=('gtkhash' 'nemo')
- make -C gtkhash-$pkgver/src/nemo DESTDIR="$pkgdir/" install
+ make -C gtkhash-$pkgver/src/nautilus DESTDIR="$pkgdir/" install
+ # remove other filemanager plugins
+ rm -rf "$pkgdir"/usr/lib/{thunarx-2,nautilus,caja}
}
package_gtkhash-nautilus() {
@@ -49,11 +46,24 @@ package_gtkhash-nautilus() {
depends=('gtkhash' 'nautilus')
make -C gtkhash-$pkgver/src/nautilus DESTDIR="$pkgdir/" install
+ # remove other filemanager plugins
+ rm -rf "$pkgdir"/usr/lib/{thunarx-2,caja,nemo}
}
package_gtkhash-thunar() {
pkgdesc+=' (Thunar filemanager plugin)'
depends=('gtkhash' 'thunar')
- make -C gtkhash-$pkgver/src/thunar DESTDIR="$pkgdir/" install
+ make -C gtkhash-$pkgver/src/nautilus DESTDIR="$pkgdir/" install
+ # remove other filemanager plugins
+ rm -rf "$pkgdir"/usr/lib/{nautilus,caja,nemo}
+}
+
+package_gtkhash-caja() {
+ pkgdesc+=' (Caja filemanager plugin)'
+ depends=('gtkhash' 'caja-gtk3')
+
+ make -C gtkhash-$pkgver/src/nautilus DESTDIR="$pkgdir/" install
+ # remove other filemanager plugins
+ rm -rf "$pkgdir"/usr/lib/{thunarx-2,nautilus,nemo}
}
diff --git a/gtkhash.desktop b/gtkhash.desktop
deleted file mode 100644
index 737449ccb714..000000000000
--- a/gtkhash.desktop
+++ /dev/null
@@ -1,8 +0,0 @@
-[Desktop Entry]
-Type=Application
-Version=1.0
-Name=gtkhash
-Exec=gtkhash
-Icon=calc
-Terminal=false
-Categories=Utility;GNOME;GTK;
diff --git a/gtkhash.install b/gtkhash.install
deleted file mode 100644
index a432ada8586d..000000000000
--- a/gtkhash.install
+++ /dev/null
@@ -1,12 +0,0 @@
-
-post_install() {
- glib-compile-schemas /usr/share/glib-2.0/schemas
-}
-
-post_upgrade() {
- post_install
-}
-
-post_remove() {
- post_install
-}