summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarsten Teibes2013-12-03 08:40:44 +0100
committerCarsten Teibes2013-12-03 08:40:44 +0100
commit7ecb6600b99d6e81dae41a652e80f658839fab25 (patch)
tree40269c9c8277bc6c39bfccd5b2355fe67f133238
downloadaur-7ecb6600b99d6e81dae41a652e80f658839fab25.tar.gz
[add] gtkhash 0.7.0
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD40
-rw-r--r--gtkhash.desktop8
-rw-r--r--gtkhash.install12
4 files changed, 82 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..afae4e6965b8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = gtkhash
+ pkgdesc = A GTK+ utility for computing message digests or checksums.
+ pkgver = 0.7.0
+ pkgrel = 1
+ url = http://gtkhash.sourceforge.net/
+ install = gtkhash.install
+ arch = i686
+ arch = x86_64
+ arch = mips64el
+ license = GPL
+ makedepends = intltool
+ depends = gtk2
+ depends = dconf
+ source = http://downloads.sourceforge.net/gtkhash/gtkhash-0.7.0.tar.xz
+ source = gtkhash.desktop
+ md5sums = f80567fdd8c4435e03b837d54f38f1bb
+ md5sums = SKIP
+ sha256sums = 161d4f27f2d412c8cb3f566ca3aa8144942bbf836c18bcb1e5f79451e6f5dfdd
+ sha256sums = SKIP
+
+pkgname = gtkhash
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2266bea7aa6a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: carstene1ns <arch carsten-teibes de>
+# Contributor: Jan Böhringer <janboe@gmail.com>
+# Contributor: Frédérik Paradis <fredy_14@live.fr>
+
+# You can also build this package with gtk3, just change lines 15+26.
+
+pkgname=gtkhash
+pkgver=0.7.0
+pkgrel=1
+pkgdesc="A GTK+ utility for computing message digests or checksums."
+arch=('i686' 'x86_64' 'mips64el')
+url="http://gtkhash.sourceforge.net/"
+license=('GPL')
+makedepends=('intltool')
+depends=('gtk2' 'dconf')
+install=$pkgname.install
+source=(http://downloads.sourceforge.net/$pkgname/$pkgname-$pkgver.tar.xz
+ gtkhash.desktop)
+md5sums=('f80567fdd8c4435e03b837d54f38f1bb'
+ 'SKIP')
+sha256sums=('161d4f27f2d412c8cb3f566ca3aa8144942bbf836c18bcb1e5f79451e6f5dfdd'
+ 'SKIP')
+
+build() {
+ cd $pkgname-$pkgver
+
+ ./configure --prefix=/usr --disable-schemas-compile \
+ --enable-linux-crypto --enable-nettle --with-gtk=2.0
+
+ make
+}
+
+package() {
+ cd $pkgname-$pkgver
+
+ make DESTDIR=$pkgdir install
+
+ # install desktop entry
+ install -Dm644 ../gtkhash.desktop $pkgdir/usr/share/applications/gtkhash.desktop
+}
diff --git a/gtkhash.desktop b/gtkhash.desktop
new file mode 100644
index 000000000000..737449ccb714
--- /dev/null
+++ b/gtkhash.desktop
@@ -0,0 +1,8 @@
+[Desktop Entry]
+Type=Application
+Version=1.0
+Name=gtkhash
+Exec=gtkhash
+Icon=calc
+Terminal=false
+Categories=Utility;GNOME;GTK;
diff --git a/gtkhash.install b/gtkhash.install
new file mode 100644
index 000000000000..a432ada8586d
--- /dev/null
+++ b/gtkhash.install
@@ -0,0 +1,12 @@
+
+post_install() {
+ glib-compile-schemas /usr/share/glib-2.0/schemas
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}