summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSantiago Burgos2022-12-29 14:22:41 -0600
committerSantiago Burgos2022-12-29 14:22:41 -0600
commit830d16d20f5f3412fc3825a4abf9e74743958ef6 (patch)
treef512209414fbc85b0cc1c3e0f53a6cacd8fcb693
parent0a6b536e0ff15daf27cadbaa191936302af3c9d8 (diff)
downloadaur-830d16d20f5f3412fc3825a4abf9e74743958ef6.tar.gz
updated to version 1.5 and migrated to meson
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD36
2 files changed, 28 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bb40d24c447d..af80c452caf0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = gtkhash
pkgdesc = A GTK+ utility for computing message digests or checksums
- pkgver = 1.4
- pkgrel = 5
+ pkgver = 1.5
+ pkgrel = 1
url = https://github.com/tristanheaven/gtkhash
arch = x86_64
license = GPL
@@ -14,13 +14,15 @@ pkgbase = gtkhash
depends = dconf
depends = gtk3
depends = libb2
+ depends = libgcrypt
+ depends = mbedtls
depends = nettle
provides = gtkhash
conflicts = gtkhash-caja
conflicts = gtkhash-nautilus
conflicts = gtkhash-nemo
conflicts = gtkhash-thunar
- source = https://github.com/tristanheaven/gtkhash/releases/download/v1.4/gtkhash-1.4.tar.xz
- sha256sums = 20b57dbb8f6c6d7323f573c111a11640603a422c5f9da7b302a4981e4adc37c4
+ source = https://github.com/tristanheaven/gtkhash/releases/download/v1.5/gtkhash-1.5.tar.xz
+ sha256sums = 7102a192eca3e82ed67a8252a6850440e50c1dbea7c6364bda154ec80f8ff005
pkgname = gtkhash
diff --git a/PKGBUILD b/PKGBUILD
index bd8dcb3bfbfe..791c5081c075 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,8 +5,8 @@
# Contributor: GI_Jack <GI_Jack@hushmail.com>
pkgname=gtkhash
-pkgver=1.4
-pkgrel=5
+pkgver=1.5
+pkgrel=1
pkgdesc="A GTK+ utility for computing message digests or checksums"
arch=('x86_64')
url="https://github.com/tristanheaven/gtkhash"
@@ -15,6 +15,8 @@ depends=(
'dconf'
'gtk3'
'libb2'
+ 'libgcrypt'
+ 'mbedtls'
'nettle'
)
@@ -34,21 +36,27 @@ conflicts=(
gtkhash-thunar
)
source=("${url}/releases/download/v$pkgver/$pkgname-$pkgver.tar.xz")
-sha256sums=('20b57dbb8f6c6d7323f573c111a11640603a422c5f9da7b302a4981e4adc37c4')
+sha256sums=('7102a192eca3e82ed67a8252a6850440e50c1dbea7c6364bda154ec80f8ff005')
+
+prepare() {
+ mkdir -p plugins
+}
-build() {
- cd gtkhash-$pkgver
- ./configure --prefix=/usr \
- --disable-schemas-compile \
- --enable-gtkhash \
- --enable-linux-crypto \
- --enable-nettle \
- --disable-blake2 \
- --with-gtk=3.0
- make
+build() {
+ arch-meson "$pkgbase-$pkgver" build \
+ -Dglib-checksums='true' \
+ -Dlinux-crypto='true' \
+ -Dmbedtls='true' \
+ -Dnettle='true' \
+ -Dbuild-caja='false' \
+ -Dbuild-nautilus='false' \
+ -Dbuild-nemo='false' \
+ -Dbuild-thunar='false'
+ meson compile -C build
}
package() {
- make -C gtkhash-$pkgver DESTDIR="$pkgdir/" install
+ meson install -C build --destdir "$pkgdir"
+
}