summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarsten Teibes2014-06-13 16:12:12 +0200
committerCarsten Teibes2014-06-13 16:12:12 +0200
commit9856c3dd73a6a0b653c99011026fdc90fb18c13e (patch)
tree0148a93c7b59fea0c4e240459abae613a4edce15
parentba4f12a680141c6f39fa783438e877491d4acde0 (diff)
downloadaur-9856c3dd73a6a0b653c99011026fdc90fb18c13e.tar.gz
[fix] Make proper split package, remove AUR hacks
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD84
2 files changed, 56 insertions, 53 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0695b45fed60..b255eae46160 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,22 +1,39 @@
pkgbase = gtkhash
pkgdesc = A GTK+ utility for computing message digests or checksums
pkgver = 0.7.0
- pkgrel = 2
+ pkgrel = 3
url = http://gtkhash.sourceforge.net/
- install = gtkhash.install
arch = i686
arch = x86_64
arch = mips64el
license = GPL
makedepends = intltool
makedepends = nemo
+ makedepends = libnautilus-extension
+ makedepends = thunar
depends = dconf
- depends = gtk2
- optdepends = nemo: filemanager plugin
+ depends = nettle
+ depends = gtk3
source = http://downloads.sourceforge.net/gtkhash/gtkhash-0.7.0.tar.xz
source = gtkhash.desktop
sha256sums = 161d4f27f2d412c8cb3f566ca3aa8144942bbf836c18bcb1e5f79451e6f5dfdd
sha256sums = f0312086093f0dd5ce0cfd6c9312abd42b57401960c39c19377372c154a32388
pkgname = gtkhash
+ install = gtkhash.install
+
+pkgname = gtkhash-nemo
+ pkgdesc = A GTK+ utility for computing message digests or checksums (Nemo filemanager plugin)
+ depends = gtkhash
+ depends = nemo
+
+pkgname = gtkhash-nautilus
+ pkgdesc = A GTK+ utility for computing message digests or checksums (Nautilus filemanager plugin)
+ depends = gtkhash
+ depends = nautilus
+
+pkgname = gtkhash-thunar
+ pkgdesc = A GTK+ utility for computing message digests or checksums (Thunar filemanager plugin)
+ depends = gtkhash
+ depends = thunar
diff --git a/PKGBUILD b/PKGBUILD
index d2532586952e..85bb0a7c4e53 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,71 +3,57 @@
# Contributor: Frédérik Paradis <fredy_14@live.fr>
# Contributor: GI_Jack <GI_Jack@hushmail.com>
-##### OPTIONS #####
-_gtk_version=2
-_nemo_plugin=y
-_nautilus_plugin=n
-_thunar_plugin=n
-###################
-
-pkgname=gtkhash
+pkgbase=gtkhash
+pkgname=(gtkhash gtkhash-nemo gtkhash-nautilus gtkhash-thunar)
pkgver=0.7.0
-pkgrel=2
+pkgrel=3
pkgdesc="A GTK+ utility for computing message digests or checksums"
arch=('i686' 'x86_64' 'mips64el')
url="http://gtkhash.sourceforge.net/"
license=('GPL')
-makedepends=('intltool')
-depends=('dconf')
-install=$pkgname.install
-source=("http://downloads.sourceforge.net/$pkgname/$pkgname-$pkgver.tar.xz"
+makedepends=('intltool' 'nemo' 'libnautilus-extension' 'thunar') # ← remove FMs here!
+depends=('dconf' 'nettle' 'gtk3')
+source=("http://downloads.sourceforge.net/gtkhash/gtkhash-$pkgver.tar.xz"
"gtkhash.desktop")
sha256sums=('161d4f27f2d412c8cb3f566ca3aa8144942bbf836c18bcb1e5f79451e6f5dfdd'
'f0312086093f0dd5ce0cfd6c9312abd42b57401960c39c19377372c154a32388')
-# gtk version
-if [ "$_gtk_version" = "3" ]; then
- _pkgoptions="$_pkgoptions --with-gtk=3.0"
- depends=("${depends[@]}" "gtk3")
-else
- _pkgoptions="$_pkgoptions --with-gtk=2.0"
- depends=("${depends[@]}" "gtk2")
-fi
+build() {
+ cd gtkhash-$pkgver
-# nemo plugin
-if [ "$_nemo_plugin" = "y" ]; then
- _pkgoptions="$_pkgoptions --enable-nemo"
- makedepends=("${makedepends[@]}" "nemo")
- optdepends=("${optdepends[@]}" "nemo: filemanager plugin")
-fi
+ ./configure --prefix=/usr --disable-schemas-compile --enable-gtkhash \
+ --enable-linux-crypto --enable-nettle --with-gtk=3.0 \
+ --enable-nemo --enable-nautilus --enable-thunar # ← remove FMs here!
+ make
+}
-# nautilus plugin
-if [ "$_nautilus_plugin" = "y" ]; then
- _pkgoptions="$_pkgoptions --enable-nautilus"
- makedepends=("${makedepends[@]}" "libnautilus-extension")
- optdepends=("${optdepends[@]}" "nautilus: filemanager plugin")
-fi
+package_gtkhash() {
+ install=gtkhash.install
-# thunar plugin
-if [ "$_thunar_plugin" = "y" ]; then
- _pkgoptions="$_pkgoptions --enable-thunar"
- makedepends=("${makedepends[@]}" "thunar")
- optdepends=("${optdepends[@]}" "thunar: filemanager plugin")
-fi
+ make -C gtkhash-$pkgver DESTDIR="$pkgdir/" install
+ # install desktop entry
+ install -Dm644 gtkhash.desktop "$pkgdir"/usr/share/applications/gtkhash.desktop
+ # remove filemanager plugins
+ rm -rf "$pkgdir"/usr/lib
+}
-build() {
- cd $pkgname-$pkgver
+package_gtkhash-nemo() {
+ pkgdesc+=' (Nemo filemanager plugin)'
+ depends=('gtkhash' 'nemo')
- ./configure --prefix=/usr --disable-schemas-compile --enable-gtkhash \
- --enable-linux-crypto --enable-nettle $_pkgoptions
- make
+ make -C gtkhash-$pkgver/src/nemo DESTDIR="$pkgdir/" install
}
-package() {
- cd $pkgname-$pkgver
+package_gtkhash-nautilus() {
+ pkgdesc+=' (Nautilus filemanager plugin)'
+ depends=('gtkhash' 'nautilus')
- make DESTDIR="$pkgdir/" install
+ make -C gtkhash-$pkgver/src/nautilus DESTDIR="$pkgdir/" install
+}
- # install desktop entry
- install -Dm644 ../gtkhash.desktop "$pkgdir"/usr/share/applications/gtkhash.desktop
+package_gtkhash-thunar() {
+ pkgdesc+=' (Thunar filemanager plugin)'
+ depends=('gtkhash' 'thunar')
+
+ make -C gtkhash-$pkgver/src/thunar DESTDIR="$pkgdir/" install
}