summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavide Iosca2016-03-02 18:57:16 +0100
committerDavide Iosca2016-03-02 18:57:16 +0100
commitca58efbdd484b006204699006674878fb5325aa6 (patch)
treedb5601be800f258664f7db05692b072e2b524695
downloadaur-gtksourceview3-highlight-cython.tar.gz
Lang file from wiki.gnome.org
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD17
2 files changed, 30 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..70aa264b1eb3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = gtksourceview3-highlight-cython
+ pkgdesc = Cython syntax highlighting for gtksourceview
+ pkgver = 20141009
+ pkgrel = 1
+ url = https://wiki.gnome.org/action/show/Projects/GtkSourceView/LanguageDefinitions
+ arch = any
+ license = GPL
+ depends = gtksourceview3
+ source = cython.lang::https://wiki.gnome.org/Projects/GtkSourceView/LanguageDefinitions?action=AttachFile&do=get&target=cython.lang
+ sha1sums = 296fea1142bdaa69a72241c6a5986bdc764fe75d
+
+pkgname = gtksourceview3-highlight-cython
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c8abaf2ca87d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,17 @@
+# Maintainer: Davide Iosca <dvdios [at] aol [dot] com>
+
+pkgname='gtksourceview3-highlight-cython'
+pkgdesc='Cython syntax highlighting for gtksourceview'
+pkgver=20141009
+pkgrel=1
+url='https://wiki.gnome.org/action/show/Projects/GtkSourceView/LanguageDefinitions'
+arch=('any')
+license=('GPL')
+depends=('gtksourceview3')
+source=('cython.lang::https://wiki.gnome.org/Projects/GtkSourceView/LanguageDefinitions?action=AttachFile&do=get&target=cython.lang')
+sha1sums=('296fea1142bdaa69a72241c6a5986bdc764fe75d')
+
+package() {
+ install -m644 -D cython.lang "${pkgdir}/usr/share/gtksourceview-3.0/language-specs/cython.lang"
+}
+