summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNicoHood2016-12-13 15:00:38 +0100
committerNicoHood2016-12-13 15:00:38 +0100
commit24a9c843d600951ca50688a828f92dbc3119ebc8 (patch)
tree71754ea3640d69e9dc031e4cd73289866503ce01
downloadaur-guestwlan.tar.gz
Initial commit of 1.0.1
-rw-r--r--.SRCINFO29
-rw-r--r--PKGBUILD30
-rw-r--r--guestwlan.install3
3 files changed, 62 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0676b182a36e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,29 @@
+pkgbase = guestwlan
+ pkgdesc = Easy & Secure Guest WLAN setup with QR code GUI and photodiashow.
+ pkgver = 1.0.1
+ pkgrel = 1
+ url = https://github.com/NicoHood/guestwlan
+ install = guestwlan.install
+ arch = any
+ license = MIT
+ depends = create_ap
+ depends = qrencode
+ depends = python
+ depends = python-kivy
+ depends = python-configobj
+ optdepends = haveged: boost low entropy
+ optdepends = rng-tools: boost low entropy
+ optdepends = fakehwclock: Save/restore system clock on machines without RTC
+ optdepends = mtdev: Raspberry Pi touch screen support
+ backup = etc/guestwlan.cfg
+ backup = etc/create_guest_ap.conf
+ source = guestwlan.install
+ source = guestwlan-1.0.1.tar.gz::https://github.com/NicoHood/guestwlan/archive/1.0.1/guestwlan-1.0.1.tar.gz
+ source = guestwlan-1.0.1.tar.gz.sig::https://github.com/NicoHood/guestwlan/releases/download/1.0.1/guestwlan-1.0.1.tar.gz.sig
+ validpgpkeys = 97312D5EB9D7AE7D0BD4307351DAE9B7C1AE9161
+ sha512sums = c9a1a174b600c52b47a8a1098887460694cfcfd0a30cb70616fae33ba04f8d683cb2b0b1de09cea8e6819a550c50de9cb92f6e37ed5be1214542f8379789ba59
+ sha512sums = 369a3858fb5a155a726614fc67e384373a5f6cc7e200b4edb775e6f9e8ed44ffcb3c0e6b6f36cba68858eb8ae5826c63e7772b9ee9c5e1937e0012764e0fbd01
+ sha512sums = SKIP
+
+pkgname = guestwlan
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1a78ca689e6e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: NicoHood <archlinux {cat} nicohood {dog} de>
+# PGP ID: 97312D5EB9D7AE7D0BD4307351DAE9B7C1AE9161
+
+pkgname=('guestwlan')
+pkgver=1.0.1
+pkgrel=1
+pkgdesc="Easy & Secure Guest WLAN setup with QR code GUI and photodiashow."
+arch=('any')
+url="https://github.com/NicoHood/guestwlan"
+license=('MIT')
+depends=('create_ap' 'qrencode' 'python' 'python-kivy' 'python-configobj')
+optdepends=('haveged: boost low entropy'
+ 'rng-tools: boost low entropy'
+ 'fakehwclock: Save/restore system clock on machines without RTC'
+ 'mtdev: Raspberry Pi touch screen support')
+install="guestwlan.install"
+backup=('etc/guestwlan.cfg'
+ 'etc/create_guest_ap.conf')
+source=("guestwlan.install"
+ "${pkgname}-${pkgver}.tar.gz::https://github.com/NicoHood/guestwlan/archive/$pkgver/$pkgname-$pkgver.tar.gz"
+ "${pkgname}-${pkgver}.tar.gz.sig::https://github.com/NicoHood/guestwlan/releases/download/${pkgver}/${pkgname}-${pkgver}.tar.gz.sig")
+sha512sums=('c9a1a174b600c52b47a8a1098887460694cfcfd0a30cb70616fae33ba04f8d683cb2b0b1de09cea8e6819a550c50de9cb92f6e37ed5be1214542f8379789ba59'
+ '369a3858fb5a155a726614fc67e384373a5f6cc7e200b4edb775e6f9e8ed44ffcb3c0e6b6f36cba68858eb8ae5826c63e7772b9ee9c5e1937e0012764e0fbd01'
+ 'SKIP')
+validpgpkeys=('97312D5EB9D7AE7D0BD4307351DAE9B7C1AE9161') # NicoHood
+
+package() {
+ make -C "${pkgname}-${pkgver}" DESTDIR="${pkgdir}" install
+ install -Dm 644 "${pkgname}-${pkgver}/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}
diff --git a/guestwlan.install b/guestwlan.install
new file mode 100644
index 000000000000..e168e2384f9f
--- /dev/null
+++ b/guestwlan.install
@@ -0,0 +1,3 @@
+post_remove() {
+ echo "Please remove files in /var/lib/guestwlan yourself."
+}