summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuis Martinez2022-07-13 12:56:06 -0500
committerLuis Martinez2022-07-13 12:56:06 -0500
commitda74612a3b04085d49189ea5048af148bd2679e0 (patch)
tree286497a5b20a2ad0a636c6b2abef759228a47cbf
parent6a9cf9b4a397b05c721ae0519209e5bc084be74a (diff)
downloadaur-guile3.tar.gz
package cleanup
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD19
2 files changed, 11 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f922619b82f3..a3d3543a013f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = guile3
pkgdesc = Portable, embeddable Scheme implementation written in C
pkgver = 3.0.8
- pkgrel = 1
+ pkgrel = 2
url = https://www.gnu.org/software/guile/
arch = x86_64
arch = pentium4
diff --git a/PKGBUILD b/PKGBUILD
index 1697a7de55d9..4542f402f80a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,9 @@
-# Maintainer: Luis Martinez <luis dot martinez at tuta dot io>
+# Maintainer: Luis Martinez <luis dot martinez at disroot dot org>
# Contributor: Rose Kunkel <rose at rosekunkel dot me>
pkgname=guile3
pkgver=3.0.8
-pkgrel=1
+pkgrel=2
pkgdesc='Portable, embeddable Scheme implementation written in C'
arch=('x86_64' 'pentium4')
url='https://www.gnu.org/software/guile/'
@@ -27,8 +27,8 @@ options=('!strip')
PURGE_TARGETS=('usr/share/aclocal/guile.m4')
prepare() {
- # Disable a test that's known to fail. See
- # https://lists.gnu.org/archive/html/bug-guile/2021-01/msg00001.html
+ # Disable a test that's known to fail.
+ # See https://lists.gnu.org/archive/html/bug-guile/2021-01/msg00001.html
patch -p1 -d "guile-$pkgver" < skip-testing-oom-conditions.patch
}
@@ -42,16 +42,17 @@ build() {
./configure \
--prefix=/usr \
--infodir="/usr/share/info/$pkgname" \
- --program-suffix=3
+ --program-suffix=3 \
+ --disable-static \
+ --disable-error-on-warning
make
}
check() {
- cd "guile-$pkgver"
- make -k check
+ make -C "guile-$pkgver" -k check
}
package() {
- cd "guile-$pkgver"
- make DESTDIR="$pkgdir/" install
+ make -C "guile-$pkgver" DESTDIR="$pkgdir/" install
+ rm "$pkgdir"/usr/lib/libguile-3.?.so.*-gdb.scm
}