summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFabien Dubosson2015-05-29 13:15:13 +0200
committerFabien Dubosson2015-05-29 13:15:13 +0200
commit46b454ab22d2aa9c36ef9bcc832284891b99c268 (patch)
treee6e11ac01d5a49d24a0ae2b492c3ae4cf6a10eff
downloadaur-46b454ab22d2aa9c36ef9bcc832284891b99c268.tar.gz
Move 'gws' into separate repo for AUR4
-rw-r--r--.SRCINFO15
-rw-r--r--ChangeLog40
-rw-r--r--PKGBUILD23
3 files changed, 78 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..40edca3b9175
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = gws
+ pkgdesc = Colorful KISS helper for git workspaces
+ pkgver = 0.1.7
+ pkgrel = 1
+ url = https://github.com/StreakyCobra/gws
+ changelog = ChangeLog
+ arch = any
+ license = MIT
+ depends = bash>4.0
+ depends = git
+ source = https://github.com/StreakyCobra/gws/archive/0.1.7.tar.gz
+ md5sums = cc987317713ae94f1e7691df5f8d2436
+
+pkgname = gws
+
diff --git a/ChangeLog b/ChangeLog
new file mode 100644
index 000000000000..781de8fab75a
--- /dev/null
+++ b/ChangeLog
@@ -0,0 +1,40 @@
+2015-03-12 Fabien Dubosson <fabien.dubosson@gmail.com>
+
+ * 0.1.7-1:
+ New upstream release
+
+2015-02-12 Fabien Dubosson <fabien.dubosson@gmail.com>
+
+ * 0.1.5-1:
+ New upstream release
+
+2014-05-11 Fabien Dubosson <fabien.dubosson@gmail.com>
+
+ * 0.1.4-1:
+ New upstream release
+
+2014-02-04 Fabien Dubosson <fabien.dubosson@gmail.com>
+
+ * 0.1.3-3:
+ Uniformalize PKGBUILD notations
+
+2014-01-20 Fabien Dubosson <fabien.dubosson@gmail.com>
+
+ * 0.1.3-2:
+ Patch minor bug, already patched upstream for future version
+
+2014-01-20 Fabien Dubosson <fabien.dubosson@gmail.com>
+
+ * 0.1.3-1:
+ New upstream release
+
+2014-01-13 Fabien Dubosson <fabien.dubosson@gmail.com>
+
+ * 0.1.2-1 :
+ New upstream release
+
+2014-01-09 Fabien Dubosson <fabien.dubosson@gmail.com>
+
+ * 0.1.1-1 :
+ Package created
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d6c2d4f25730
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Fabien Dubosson <fabien.dubosson@gmail.com>
+
+pkgname="gws"
+pkgver="0.1.7"
+pkgrel="1"
+pkgdesc="Colorful KISS helper for git workspaces"
+url="https://github.com/StreakyCobra/gws"
+license=('MIT')
+arch=('any')
+depends=('bash>4.0' 'git')
+changelog="ChangeLog"
+source=("https://github.com/StreakyCobra/${pkgname}/archive/${pkgver}.tar.gz")
+md5sums=('cc987317713ae94f1e7691df5f8d2436')
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}/"
+
+ install -D -m755 'src/gws' "${pkgdir}/usr/bin/${pkgname}"
+ install -D -m755 'completions/zsh' "${pkgdir}/usr/share/zsh/site-functions/_${pkgname}"
+ install -D -m755 'completions/bash' "${pkgdir}/usr/share/bash-completion/completions/${pkgname}"
+}
+
+# vim:set ts=4 sw=4 et: