summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLubosz Sarnecki2022-10-13 17:13:30 +0200
committerLubosz Sarnecki2022-11-04 12:56:47 +0100
commit40b26ceed969b7c1765dac4aae8937721e10c31d (patch)
tree5fcd780493f2d9a340298c436ccbbfe3d9837fdd
parentb48b99d43bbc9d4d7294e11d89bb866a64bba23f (diff)
downloadaur-40b26ceed969b7c1765dac4aae8937721e10c31d.tar.gz
Update to main branch and 0.16.
-rw-r--r--PKGBUILD19
1 files changed, 9 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3dc59789d6dc..83c839f46c78 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,21 @@
# Maintainer: Lubosz Sarnecki <lubosz.sarnecki@collabora.com>
-
+
_realname='gxr'
pkgname="$_realname-git"
-pkgver=0.15.1.979.8894a85
+pkgver=0.16.0.1148.b204356
pkgrel=1
pkgdesc='A glib wrapper for the OpenVR and OpenXR APIs.'
arch=('i686' 'x86_64')
url='https://gitlab.freedesktop.org/xrdesktop/gxr'
-depends=('gtk3' 'gulkan-git' 'openvr' 'openxr')
+depends=('gtk3' 'gulkan-git' 'openxr')
provides=("$_realname="$pkgver)
conflicts=("$_realname")
makedepends=('meson' 'git' 'vulkan-headers' 'gtk-doc')
license=('MIT')
-
-source=('git+https://gitlab.freedesktop.org/xrdesktop/gxr.git')
-optdepends=('monado-git: The open source OpenXR runtime.'
- 'steam: For SteamVR.')
+source=('git+https://gitlab.freedesktop.org/xrdesktop/gxr.git#branch=main')
+
+optdepends=('monado-git: The open source OpenXR runtime.')
md5sums=('SKIP')
@@ -38,9 +37,9 @@ build() {
ninja -C build
}
-check() {
- meson test -C build/ --no-suite xr
-}
+#check() {
+# meson test -C build/ --no-suite xr
+#}
package() {
DESTDIR="$pkgdir" ninja -C build install