summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRyan Cragun2019-11-14 11:40:55 -0700
committerRyan Cragun2019-11-14 11:40:55 -0700
commit4c4117cdcaa607bf38aef510e471247bea795555 (patch)
treec5ca8faadd0785d8d1a286e9ae6c1017834c7d86
parent7951138c6018385a0187fa24bb0e3ce592982756 (diff)
downloadaur-4c4117cdcaa607bf38aef510e471247bea795555.tar.gz
Update to hab 0.90.6-1
Signed-off-by: Ryan Cragun <ryan@chef.io>
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD14
2 files changed, 9 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9a4b6cbae4a0..60f2c3faec5a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = habitat-bin
pkgdesc = Application automation framework that allows you to build applications that have automation built-in
- pkgver = 0.88.0
+ pkgver = 0.90.6
pkgrel = 1
url = https://www.habitat.sh/
arch = x86_64
@@ -8,8 +8,8 @@ pkgbase = habitat-bin
provides = habitat
conflicts = habitat
conflicts = habitat-git
- source = https://dl.bintray.com/habitat/stable/linux/x86_64/hab-0.88.0-20191009204957-x86_64-linux.tar.gz
- sha256sums = 2a0bd903f395c441069bc618e48c20f175877f5f11c42765d7327866ee89ee60
+ source = https://packages.chef.io/files/habitat/0.90.6/hab-x86_64-linux.tar.gz
+ sha256sums = 611181dc7294dca5e44dfc7e7095da8bdcb53dcd32cafc6b8200cd4f010d775d
pkgname = habitat-bin
diff --git a/PKGBUILD b/PKGBUILD
index 591904aa5efd..6d405606e1ac 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,8 @@
# Maintainer: Ryan Cragun <me@ryan.ec>
-
+# http://packages.chef.io/files/stable/habitat/latest/manifest.json
pkgname=habitat-bin
-pkgver=0.88.0
-_builddate=20191009204957
-
+pkgver=0.90.6
+_pkgrelease=20191112141314
pkgrel=1
pkgdesc="Application automation framework that allows you to build applications that have automation built-in"
arch=('x86_64')
@@ -11,9 +10,8 @@ url="https://www.habitat.sh/"
license=('Apache')
provides=('habitat')
conflicts=('habitat' 'habitat-git')
-source=("https://dl.bintray.com/habitat/stable/linux/${arch}/hab-${pkgver}-${_builddate}-${arch}-linux.tar.gz")
-sha256sums=('2a0bd903f395c441069bc618e48c20f175877f5f11c42765d7327866ee89ee60')
-
+source=("https://packages.chef.io/files/habitat/${pkgver}/hab-${arch}-linux.tar.gz")
+sha256sums=('611181dc7294dca5e44dfc7e7095da8bdcb53dcd32cafc6b8200cd4f010d775d')
package() {
- install -D -m755 "${srcdir}/hab-${pkgver}-${_builddate}-${arch}-linux/hab" "${pkgdir}/usr/bin/hab"
+ install -D -m755 "${srcdir}/hab-${pkgver}-${_pkgrelease}-${arch}-linux/hab" "${pkgdir}/usr/bin/hab"
}