summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRadioLogic2024-02-15 14:44:39 -0500
committerRadioLogic2024-02-15 14:44:39 -0500
commit7d568d1cfc0042bca17dad6b6d87ef206d48312a (patch)
tree44ea8de13eca133ce66ab05e6f1503f3f58225f7
downloadaur-hak5-payloadstudio-web.tar.gz
Initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD37
-rw-r--r--hak5-payloadstudio-web.install37
4 files changed, 92 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..73885667aa7b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = hak5-payloadstudio-web
+ pkgdesc = Hak5 Payload Studio for writing and compiling DuckyScript
+ pkgver = 1.3.1
+ pkgrel = 1
+ url = https://payloadstudio.com/community/
+ install = hak5-payloadstudio-web.install
+ arch = any
+ license = none
+ makedepends = wget
+ provides = hak5-payloadstudio
+ conflicts = hak5-payloadstudio-html
+ replaces = hak5-payloadstudio-html
+ options = !strip
+
+pkgname = hak5-payloadstudio-web
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..57a868c40327
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+/pkg
+/src
+*.tar.zst
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..25484d948bb8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: RadioLogic <ncottrellweb at gmail dot com>
+
+pkgname="hak5-payloadstudio-web"
+pkgver=1.3.1
+pkgrel=1
+pkgdesc="Hak5 Payload Studio for writing and compiling DuckyScript"
+url="https://payloadstudio.com/community/"
+license=("none")
+arch=("any")
+provides=("${pkgname%-web}")
+conflicts=("hak5-payloadstudio-html")
+replaces=("hak5-payloadstudio-html")
+makedepends=("wget")
+install=${pkgname}.install
+options=("!strip")
+
+prepare() {
+ # Downloading hak5 payload studio for future corrections
+ wget --no-parent --no-host-directories --page-requisites --convert-links \
+ --relative --directory-prefix=${srcdir} ${url}
+}
+
+pkgver() {
+ # Grepping index file for version
+ cat "${srcdir}/community/index.html" | tr '\n' ' ' | grep -oP 'Version\s+\K[0-9]+\.[0-9]+\.[0-9]+'
+}
+
+package() {
+ # Installing into /usr/share
+ install -d ${pkgdir}/usr/share/${pkgname%-web}/
+ cp -r ${srcdir}/community/* ${pkgdir}/usr/share/${pkgname%-web}/
+
+ # Setting proper permissions
+ find ${pkgdir}/usr/share/${pkgname%-web}/ -type d -exec chmod 755 {} \;
+ find ${pkgdir}/usr/share/${pkgname%-web}/ -type f -exec chmod 644 {} \;
+ # chmod -R 755 ${pkgdir}/usr/share/${pkgname%-web}/
+}
diff --git a/hak5-payloadstudio-web.install b/hak5-payloadstudio-web.install
new file mode 100644
index 000000000000..fce672b0e55d
--- /dev/null
+++ b/hak5-payloadstudio-web.install
@@ -0,0 +1,37 @@
+# This is a default template for a post-install scriptlet.
+# Uncomment only required functions and remove any functions
+# you don't need (and this header).
+
+## arg 1: the new package version
+#pre_install() {
+ # do something here
+#}
+
+## arg 1: the new package version
+post_install() {
+ # Print where to access new html files
+ echo "Hak5 PayloadStudio has successfully been installed under /usr/share/hak5-payloadstudio/"
+ echo "See IDE in browser with file:///usr/share/hak5-payloadstudio/index.html"
+}
+
+## arg 1: the new package version
+## arg 2: the old package version
+#pre_upgrade() {
+ # do something here
+#}
+
+## arg 1: the new package version
+## arg 2: the old package version
+#post_upgrade() {
+ # do something here
+#}
+
+## arg 1: the old package version
+#pre_remove() {
+ # do something here
+#}
+
+## arg 1: the old package version
+#post_remove() {
+ # do something here
+#}