summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohan Svensson2015-06-16 11:29:15 +0200
committerJohan Svensson2015-06-16 11:29:15 +0200
commit949fb8fda0de263038469dbaf21cf4e94f7d1280 (patch)
treedc65ccbdf08a543feb9e625e2de6fd69160c486d
downloadaur-halonadm.tar.gz
Initial import
-rw-r--r--.AURINFO15
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD25
-rw-r--r--halonadm.install9
4 files changed, 65 insertions, 0 deletions
diff --git a/.AURINFO b/.AURINFO
new file mode 100644
index 000000000000..6f2878f94cf9
--- /dev/null
+++ b/.AURINFO
@@ -0,0 +1,15 @@
+pkgbase = halonadm
+ pkgdesc = Manage Halon (http://halon.se) SP servers easily
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = https://github.com/loxley/halonadm
+ install = halonadm.install
+ arch = any
+ license = GPLv2
+ makedepends = python-setuptools
+ depends = python3
+ depends = python-suds-jurko
+ source = https://pypi.python.org/packages/source/h/halonadm/halonadm-1.0.0.tar.gz
+
+pkgname = halonadm
+
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c91fd150232c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = halonadm
+ pkgdesc = Manage Halon (http://halon.se) SP servers easily
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = https://github.com/loxley/halonadm
+ install = halonadm.install
+ arch = any
+ license = GPLv2
+ makedepends = python-setuptools
+ depends = python3
+ depends = python-suds-jurko
+ source = https://pypi.python.org/packages/source/h/halonadm/halonadm-1.0.0.tar.gz
+ sha512sums = b6cb2349cfabb3ce70cbf02fd46b33316db1f742bd07311ab17db8ea01bf1bd5760907b745758113a0dcd799db564ca4f0b146c1086635a4643e5a219bcfbd05
+
+pkgname = halonadm
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..95a1de515338
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Johan Svensson <johan@loxley.se>
+pkgname=halonadm
+pkgver=1.0.0
+pkgrel=1
+pkgdesc="Manage Halon (http://halon.se) SP servers easily"
+url="https://github.com/loxley/halonadm"
+arch=('any')
+license="GPLv2"
+depends=('python3'
+ 'python-suds-jurko')
+makedepends=('python-setuptools')
+source=("https://pypi.python.org/packages/source/h/halonadm/halonadm-${pkgver}.tar.gz")
+sha512sums=('b6cb2349cfabb3ce70cbf02fd46b33316db1f742bd07311ab17db8ea01bf1bd5760907b745758113a0dcd799db564ca4f0b146c1086635a4643e5a219bcfbd05')
+install=halonadm.install
+
+build() {
+ cd halonadm-${pkgver}
+ python3 setup.py build
+}
+
+package() {
+ cd halonadm-${pkgver}
+ python3 setup.py install --root="${pkgdir}" -O1
+
+}
diff --git a/halonadm.install b/halonadm.install
new file mode 100644
index 000000000000..cbc80aeabac6
--- /dev/null
+++ b/halonadm.install
@@ -0,0 +1,9 @@
+post_install() {
+cat <<End-of-message
+
+ Sample config is located in /usr/lib/python3.4/site-packages/halonadm/halonadm.conf.
+ Copy it to ~/.config/halonadm/halonadm.conf or ~/.halonadm.conf and fill in the
+ needed values.
+
+End-of-message
+}