summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlex Szczuczko2016-02-14 19:42:15 +0000
committerAlex Szczuczko2016-02-14 19:45:05 +0000
commit767483157f8667d08eae68797c36b5fece87e663 (patch)
tree21dc8e291263527ee3b609300a5dac4dd03cca9e
parent03e5160c414a361492b618805fed82c3da228fea (diff)
downloadaur-handoffate-gog.tar.gz
Update for new version and source format
-rw-r--r--.SRCINFO10
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD29
-rw-r--r--launch.sh3
4 files changed, 25 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 909721a29bec..32afa0cdbd83 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,8 @@
+# Generated by mksrcinfo v8
+# Sun Feb 14 19:42:05 UTC 2016
pkgbase = handoffate-gog
pkgdesc = A hybrid roguelike/action-RPG/deck builder
- pkgver = 1.0.0.1
+ pkgver = 2.7.0.9
pkgrel = 1
url = http://www.gog.com/game/hand_of_fate
arch = i686
@@ -21,9 +23,11 @@ pkgbase = handoffate-gog
depends = libxrender
depends = libgl
source = handoffate-gog.desktop
- source = gog_hand_of_fate_1.0.0.1.tar.gz::file://gog_hand_of_fate_1.0.0.1.tar.gz
+ source = launch.sh
+ source = gog_hand_of_fate_2.7.0.9.sh::file://gog_hand_of_fate_2.7.0.9.sh
sha256sums = 065176e1ddc31fdb96af3f7910522573fdace45ff931763b05b1e3ec7797efe9
- sha256sums = 9e1265898618f3d55ad022b5dd932b8bdd0752eb042a3b387fe1a2ab6996f494
+ sha256sums = 6262d1bbe1d7e99fa019905cff634b660466476f7431dcddd37b499790e14485
+ sha256sums = ec446a2fcc7755179fc8f0ae25ede2cf3ae50bcbb163d7f47aed9ca15334b24f
pkgname = handoffate-gog
diff --git a/.gitignore b/.gitignore
index eb262a6faa46..6b63655b8be8 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,4 +1,5 @@
*.swp
+*.sh
*.tar.gz
*.tar.xz
*.tar
diff --git a/PKGBUILD b/PKGBUILD
index 069967c820ec..95b46a933eaf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,30 +1,28 @@
# Maintainer: Alex Szczuczko <alex@szc.ca>
pkgname=handoffate-gog
-pkgver=1.0.0.1
+pkgver=2.7.0.9
pkgrel=1
pkgdesc="A hybrid roguelike/action-RPG/deck builder"
arch=("i686" "x86_64")
url="http://www.gog.com/game/hand_of_fate"
license=("custom:commercial")
options=()
-depends=()
+depends=("gcc-libs" "gcc-libs-multilib" "glibc" "glu" "libx11" "libxau" "libxcb" "libxcursor" "libxdmcp" "libxext" "libxfixes" "libxrandr" "libxrender" "libgl")
source=("${pkgname}.desktop"
- "gog_hand_of_fate_${pkgver}.tar.gz::file://gog_hand_of_fate_${pkgver}.tar.gz")
+ "launch.sh"
+ "gog_hand_of_fate_${pkgver}.sh::file://gog_hand_of_fate_${pkgver}.sh")
sha256sums=("065176e1ddc31fdb96af3f7910522573fdace45ff931763b05b1e3ec7797efe9"
- "9e1265898618f3d55ad022b5dd932b8bdd0752eb042a3b387fe1a2ab6996f494")
-
-# Modify depends for the arch type
-if [ "$CARCH" = "x86_64" ]
-then
- depends+=("lib32-gcc-libs" "lib32-glibc" "lib32-glu" "lib32-libx11" "lib32-libxau" "lib32-libxcb" "lib32-libxcursor" "lib32-libxdmcp" "lib32-libxext" "lib32-libxfixes" "lib32-libxrandr" "lib32-libxrender" "lib32-libgl")
-else
- depends+=("gcc-libs" "gcc-libs-multilib" "glibc" "glu" "libx11" "libxau" "libxcb" "libxcursor" "libxdmcp" "libxext" "libxfixes" "libxrandr" "libxrender" "libgl")
-fi
+ "6262d1bbe1d7e99fa019905cff634b660466476f7431dcddd37b499790e14485"
+ "ec446a2fcc7755179fc8f0ae25ede2cf3ae50bcbb163d7f47aed9ca15334b24f")
# Disable compression of the package
PKGEXT=".pkg.tar"
+prepare() {
+ ln -s "data/noarch/" "$srcdir/Hand of Fate"
+}
+
package() {
# Binaries
if [ "$CARCH" = "x86_64" ]
@@ -33,6 +31,7 @@ package() {
else
install -Dm755 "$srcdir/Hand of Fate/game/Hand of Fate.x86" "$pkgdir/opt/$pkgname/game/Hand of Fate"
fi
+ install -m755 "$srcdir/launch.sh" "$pkgdir/opt/$pkgname/game/launch.sh"
# Data
# Hardlink files to save the disk space and time spent copying them (they are large)
@@ -46,7 +45,7 @@ package() {
"$srcdir/Hand of Fate/docs/End User License Agreement.txt"
# Icon
- install -m644 -t "$pkgdir/opt/$pkgname/" "$srcdir/Hand of Fate/support/gog-hand-of-fate.png"
+ install -m644 -t "$pkgdir/opt/$pkgname/" "$srcdir/Hand of Fate/support/icon.png"
#
# System integration
@@ -54,7 +53,7 @@ package() {
# /bin
install -m755 -d "$pkgdir/usr/bin/"
- ln -s "/opt/$pkgname/game/Hand of Fate" "$pkgdir/usr/bin/$pkgname"
+ ln -s "/opt/$pkgname/game/launch.sh" "$pkgdir/usr/bin/$pkgname"
# License
install -m755 -d "$pkgdir/usr/share/licenses/$pkgname/"
@@ -62,7 +61,7 @@ package() {
# Icon
install -m755 -d "$pkgdir/usr/share/pixmaps/"
- ln -s "/opt/$pkgname/gog-hand-of-fate.png" "$pkgdir/usr/share/pixmaps/${pkgname}.png"
+ ln -s "/opt/$pkgname/icon.png" "$pkgdir/usr/share/pixmaps/${pkgname}.png"
# .desktop File
install -m755 -d "$pkgdir/usr/share/applications/"
diff --git a/launch.sh b/launch.sh
new file mode 100644
index 000000000000..4f6959fa49e4
--- /dev/null
+++ b/launch.sh
@@ -0,0 +1,3 @@
+#!/bin/sh
+cd "/opt/handoffate-gog/game"
+exec "./Hand of Fate" "$@"