summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTosuke2017-07-31 11:19:28 +0900
committerTosuke2017-07-31 11:19:28 +0900
commitcbf4d69912c59bd7925c3cfb9c2d44f741bc6f32 (patch)
tree946556f0aa1af1912cd9b1ab0056930bd3dce88f
downloadaur-harbored-mod.tar.gz
initial
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD35
2 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3bbd7fe10bcb
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+# Generated by mksrcinfo v8
+# Mon Jul 31 02:18:28 UTC 2017
+pkgbase = harbored-mod
+ pkgdesc = A documentation generator for D with support for both DDoc and Markdown.
+ pkgver = 0.2.1
+ pkgrel = 1
+ url = https://github.com/dlang-community/harbored-mod
+ arch = i686
+ arch = x86_64
+ license = Boost Software License
+ makedepends = dmd
+ makedepends = git
+ depends = libphobos
+ source = git+https://github.com/dlang-community/harbored-mod#tag=v0.2.1
+ sha256sums = SKIP
+
+pkgname = harbored-mod
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f59dacdba0ba
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Tosuke <tasukeprg at gmail dot com>
+
+pkgname=('harbored-mod')
+pkgver=0.2.1
+pkgrel=1
+pkgdesc="A documentation generator for D with support for both DDoc and Markdown."
+arch=('i686' 'x86_64')
+url="https://github.com/dlang-community/harbored-mod"
+license=('Boost Software License')
+makedepends=('dmd' 'git')
+depends=('libphobos')
+
+source=("git+https://github.com/dlang-community/harbored-mod#tag=v$pkgver")
+sha256sums=("SKIP")
+
+prepare() {
+ cd "$srcdir/harbored-mod"
+
+ git submodule update --init --recursive
+}
+
+build() {
+ cd "$srcdir/harbored-mod"
+ make
+}
+
+package() {
+ # binaries
+ install -Dm755 "$srcdir/harbored-mod/bin/hmod" "$pkgdir/usr/bin/hmod"
+
+ # licence
+ install -Dm755 "$srcdir/harbored-mod/LICENSE_1_0.txt" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}
+
+