summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2024-01-20 16:11:39 -0700
committerMark Wagie2024-01-20 16:11:39 -0700
commit41d8d9bccbad83d0e750e82ad9b5086f375825fb (patch)
tree3467a6931ab48ea1fc35965afa83db3a1bb1423c
parent79482ad321a74e4fa3ea07db57c2705a288f0bdd (diff)
downloadaur-hardcode-tray-git.tar.gz
Rename and correct path for motrix
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD10
2 files changed, 9 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2ed4dd3dc811..74f8df0d2037 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,10 @@
pkgbase = hardcode-tray-git
pkgdesc = Fixes hardcoded tray icons
pkgver = 4.3.r246.g1d52b2c
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/bil-elmoussaoui/Hardcode-Tray
arch = x86_64
- license = GPL3
+ license = GPL-3.0-or-later
makedepends = git
makedepends = gobject-introspection
makedepends = meson
diff --git a/PKGBUILD b/PKGBUILD
index 7ccd07b4869d..9899c9c79f15 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,11 +3,11 @@
# Contributor: Bilal Elmoussaoui <bil.elmoussaoui@gmail.com>
pkgname=hardcode-tray-git
pkgver=4.3.r246.g1d52b2c
-pkgrel=1
+pkgrel=2
pkgdesc="Fixes hardcoded tray icons"
arch=('x86_64')
url="https://github.com/bil-elmoussaoui/Hardcode-Tray"
-license=('GPL3')
+license=('GPL-3.0-or-later')
depends=('gtk3' 'librsvg' 'python-cairosvg' 'python-gobject')
makedepends=('git' 'gobject-introspection' 'meson')
optdepends=('nodejs-svgexport: option to convert svg to png'
@@ -30,9 +30,13 @@ pkgver() {
prepare() {
cd Hardcode-Tray
- # Correct app.asar path for community bitwarden package
+ # Correct app.asar path for bitwarden
sed -i 's|/usr/lib/bitwarden/resources/|/usr/lib/bitwarden/|g' \
data/database/bitwarden.electron.json
+
+ # Rename and correct path for motrix
+ mv data/database/motrix-git.json data/database/motrix.json
+ sed -i 's|/usr/lib/motrix/app/electron/static/|/usr/lib/motrix/|g' data/database/motrix.json
}
build() {