summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBao Trinh2024-04-15 11:34:19 -0500
committerBao Trinh2024-04-15 11:34:19 -0500
commit0f75b0ebb4839dff015bbf0f9243a18970f37341 (patch)
tree07f9bfd868c587d6dac317bd8a3809cc39f8e613
parent8ac7c9c71f679ebfb988fe546aaf927957923762 (diff)
downloadaur-hare-madeline.tar.gz
v0.1 (+patches for hare v0.1 compat)
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD17
2 files changed, 14 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 15d4ecfec9d3..6f2fec2bcad3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,13 @@
pkgbase = hare-madeline
pkgdesc = tiny readline-alike with some batteries included
- pkgver = r136.58698e5
+ pkgver = 0.1.r29.g54dcf14
pkgrel = 1
- url = https://git.d2evs.net/~ecs/madeline
+ url = https://git.sr.ht/~ecs/madeline
arch = any
license = custom:WTFPL
makedepends = git
depends = hare
- source = hare-madeline::git+https://git.d2evs.net/~ecs/madeline#commit=58698e5ccf19a44d49315f76033165a5d903b8b3
- md5sums = SKIP
+ source = hare-madeline::git+https://git.sr.ht/~ecs/madeline#commit=54dcf14b67f34da392be837d01889e2956905d68
+ sha256sums = ebd1698d60a88948521163aa12e7a558672356e58741d72ee446f94e0cb57b87
pkgname = hare-madeline
diff --git a/PKGBUILD b/PKGBUILD
index 3e11ca120e70..940eeaee2e2e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,23 @@
# Maintainer: Bao Trinh <qubidt at gmail dot com>
-pkgname=hare-madeline
-pkgver=r136.58698e5
+_pkgname=madeline
+pkgname=hare-${_pkgname}
+pkgver=0.1.r29.g54dcf14
+_commit='54dcf14b67f34da392be837d01889e2956905d68'
pkgrel=1
pkgdesc='tiny readline-alike with some batteries included'
arch=('any')
-url='https://git.d2evs.net/~ecs/madeline'
+url='https://git.sr.ht/~ecs/madeline'
license=('custom:WTFPL')
-depends=('hare') # >=r2843
+depends=('hare')
makedepends=('git')
-_commit='58698e5ccf19a44d49315f76033165a5d903b8b3'
source=("${pkgname}::git+${url}#commit=${_commit}")
-md5sums=('SKIP')
+sha256sums=('ebd1698d60a88948521163aa12e7a558672356e58741d72ee446f94e0cb57b87')
pkgver() {
cd "${pkgname}"
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ # shellcheck disable=2312
+ git describe --long --tags --abbrev=7 | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
check() {
@@ -29,4 +31,5 @@ package() {
cp -avt "${pkgdir}/usr/src/hare/third-party" "graph" "made"
install -Dm644 -t "${pkgdir}/usr/share/licenses/${pkgname}" "LICENSE"
install -Dm644 -t "${pkgdir}/usr/share/doc/${pkgname}" "README"
+ install -Dm644 -t "${pkgdir}/usr/share/doc/${pkgname}" "example.ha"
}