summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJosé Joaquín Zubieta Rico2022-05-25 14:18:53 -0500
committerJosé Joaquín Zubieta Rico2022-05-25 14:20:24 -0500
commit73ddb7946c0af105e2a82ca3e9f044c01a21c89e (patch)
tree56a0f26e962e191ba2e973882c4ea1fb1fbee627
downloadaur-harvest-bin.tar.gz
add first version
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD23
2 files changed, 36 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..964b185605e5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = harvest-bin
+ pkgdesc = Tool to sort large collections of files according to common typologies
+ pkgver = 0.8
+ pkgrel = 1
+ url = https://github.com/dyne/harvest
+ arch = x86_64
+ license = GPL3
+ depends = gcc-libs
+ conflicts = harvest
+ source = https://github.com/dyne/harvest/releases/download/v0.8/harvest.elf
+ sha512sums = 1912bc5019dc4f1a55855cfcc589e9b248b23dee182155f296d0160f76bd30989ba2b103036a78fca2d3784fd4c3627f741a52afc4d45d305dace4ca695b2019
+
+pkgname = harvest-bin
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fefc605516f6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: José Joaquín Zubieta Rico <flyingspaghetti@airmail.cc>
+
+pkgname='harvest-bin'
+pkgver=0.8
+pkgrel=1
+pkgdesc='Tool to sort large collections of files according to common typologies'
+arch=('x86_64')
+url='https://github.com/dyne/harvest'
+license=('GPL3')
+depends=('gcc-libs')
+conflicts=('harvest')
+source=(https://github.com/dyne/harvest/releases/download/v${pkgver}/harvest.elf)
+sha512sums=('1912bc5019dc4f1a55855cfcc589e9b248b23dee182155f296d0160f76bd30989ba2b103036a78fca2d3784fd4c3627f741a52afc4d45d305dace4ca695b2019')
+_prefix=usr
+
+prepare() {
+ mv harvest.elf harvest
+}
+
+package() {
+ install -Dm755 harvest "$pkgdir/$_prefix/bin/harvest"
+}
+