summarylogtreecommitdiffstats
diff options
context:
space:
mode:
author71e6fd522020-06-14 16:39:57 +0800
committer71e6fd522020-06-14 16:39:57 +0800
commit47735f5948efcbabc7c1a38a6b5bf4d860401ef3 (patch)
tree74ac7582903e68a7e6bd8884a77c40c1b133f9bc
parentaca0f3b9c39ab88b68a6e6d5b7b7b25ec699c0a4 (diff)
downloadaur-haskell-butcher.tar.gz
1.3.3.2
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD18
2 files changed, 11 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b7bcd944fea2..29b69dd11e5b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,28 +1,24 @@
pkgbase = haskell-butcher
pkgdesc = Chops a command or program invocation into digestable pieces.
- pkgver = 1.3.2.3
+ pkgver = 1.3.3.2
pkgrel = 1
url = https://hackage.haskell.org/package/butcher
arch = x86_64
- license = BSD3
+ license = BSD
makedepends = ghc
depends = ghc-libs
depends = haskell-bifunctors
- depends = haskell-containers
depends = haskell-deque
depends = haskell-extra
depends = haskell-free
depends = haskell-hspec
depends = haskell-microlens
depends = haskell-microlens-th
- depends = haskell-mtl
depends = haskell-multistate
- depends = haskell-pretty
- depends = haskell-transformers
depends = haskell-unsafe
depends = haskell-void
- source = https://hackage.haskell.org/packages/archive/butcher/1.3.2.3/butcher-1.3.2.3.tar.gz
- sha512sums = 55e2fc0ee8d35ddd90a7e6bbf65355423f7d71a3e1097f0a93706361f10796773b717d5e2e17c700fa7f7c7fa6fdef9aaa0f103af755fa06523b684f162018d4
+ source = https://hackage.haskell.org/packages/archive/butcher/1.3.3.2/butcher-1.3.3.2.tar.gz
+ sha512sums = 98dece006460c00280ef16ea66d91405644e10e496059e5f1412ec8461674f1eca6a3d429800611329351b35d60855d69f21be9d9a96ed027b6e4b5f2c000703
pkgname = haskell-butcher
diff --git a/PKGBUILD b/PKGBUILD
index 3bbd00d05bb0..2cf8742c1848 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,29 +2,25 @@
_hkgname=butcher
pkgname=haskell-butcher
-pkgver=1.3.2.3
+pkgver=1.3.3.2
pkgrel=1
-pkgdesc='Chops a command or program invocation into digestable pieces.'
+pkgdesc="Chops a command or program invocation into digestable pieces."
url='https://hackage.haskell.org/package/butcher'
license=('BSD')
arch=('x86_64')
-depends=('ghc-libs' 'haskell-bifunctors' 'haskell-containers' 'haskell-deque' 'haskell-extra' 'haskell-free' 'haskell-hspec' 'haskell-microlens' 'haskell-microlens-th' 'haskell-mtl' 'haskell-multistate' 'haskell-pretty' 'haskell-transformers' 'haskell-unsafe' 'haskell-void')
+depends=('ghc-libs' 'haskell-bifunctors' 'haskell-deque' 'haskell-extra' 'haskell-free' 'haskell-hspec' 'haskell-microlens' 'haskell-microlens-th' 'haskell-multistate' 'haskell-unsafe' 'haskell-void')
makedepends=('ghc')
source=("https://hackage.haskell.org/packages/archive/${_hkgname}/${pkgver}/${_hkgname}-${pkgver}.tar.gz")
-sha512sums=('55e2fc0ee8d35ddd90a7e6bbf65355423f7d71a3e1097f0a93706361f10796773b717d5e2e17c700fa7f7c7fa6fdef9aaa0f103af755fa06523b684f162018d4')
-
-prepare() {
- cd $_hkgname-$pkgver
-
- sed -i 's/base .*$/base/' butcher.cabal
-}
+sha512sums=('98dece006460c00280ef16ea66d91405644e10e496059e5f1412ec8461674f1eca6a3d429800611329351b35d60855d69f21be9d9a96ed027b6e4b5f2c000703')
build() {
cd $_hkgname-$pkgver
runhaskell Setup configure -O --enable-shared --enable-executable-dynamic --disable-library-vanilla \
--prefix=/usr --docdir=/usr/share/doc/$pkgname --enable-tests \
- --dynlibdir=/usr/lib --libsubdir=\$compiler/site-local/\$pkgid
+ --dynlibdir=/usr/lib --libsubdir=\$compiler/site-local/\$pkgid \
+ --ghc-option=-optl-Wl\,-z\,relro\,-z\,now \
+ --ghc-option='-pie'
runhaskell Setup build
runhaskell Setup register --gen-script
runhaskell Setup unregister --gen-script