summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Nagy2015-06-08 20:28:16 +0200
committerDaniel Nagy2015-06-08 20:28:16 +0200
commit2d6e2c14f76c16cf42c812da256cad89563fb254 (patch)
treed1e9c71dfcfa9c5b173b56a7d4cbc7cf9c0f8750
downloadaur-haskell-chp.tar.gz
import to aur4
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD37
-rw-r--r--haskell-chp.install18
3 files changed, 76 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..75f9c8042f58
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = haskell-chp
+ pkgdesc = An implementation of concurrency ideas from Communicating Sequential Processes
+ pkgver = 2.2.0
+ pkgrel = 3
+ url = http://hackage.haskell.org/package/chp
+ install = haskell-chp.install
+ arch = i686
+ arch = x86_64
+ license = custom:BSD3
+ depends = ghc
+ depends = haskell-containers=0.3.0.0
+ depends = haskell-deepseq=1.1.0.0
+ depends = haskell-extensible-exceptions=0.1.1.1
+ depends = haskell-pretty=1.0.1.1
+ depends = haskell-stm=2.1.2.1
+ options = strip
+ source = http://hackage.haskell.org/packages/archive/chp/2.2.0/chp-2.2.0.tar.gz
+ md5sums = 42de2a6c847169c693e0ba2282c91432
+
+pkgname = haskell-chp
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0c5cb5e750b4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Daniel Nagy <danielnagy at gmx de>
+# Contributor: Arch Haskell Team <arch-haskell@haskell.org>
+
+_hkgname=chp
+pkgname=haskell-chp
+pkgver=2.2.0
+pkgrel=3
+pkgdesc="An implementation of concurrency ideas from Communicating Sequential Processes"
+url="http://hackage.haskell.org/package/${_hkgname}"
+license=('custom:BSD3')
+arch=('i686' 'x86_64')
+makedepends=()
+depends=('ghc' 'haskell-containers=0.3.0.0' 'haskell-deepseq=1.1.0.0' 'haskell-extensible-exceptions=0.1.1.1' 'haskell-pretty=1.0.1.1' 'haskell-stm=2.1.2.1')
+options=('strip')
+source=(http://hackage.haskell.org/packages/archive/${_hkgname}/${pkgver}/${_hkgname}-${pkgver}.tar.gz)
+install=${pkgname}.install
+build() {
+ cd ${srcdir}/${_hkgname}-${pkgver}
+ runhaskell Setup configure -O --enable-split-objs --enable-shared \
+ --prefix=/usr --docdir=/usr/share/doc/${pkgname} --libsubdir=\$compiler/site-local/\$pkgid
+ runhaskell Setup build
+ runhaskell Setup haddock
+ runhaskell Setup register --gen-script
+ runhaskell Setup unregister --gen-script
+ sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
+}
+package() {
+ cd ${srcdir}/${_hkgname}-${pkgver}
+ install -D -m744 register.sh ${pkgdir}/usr/share/haskell/${pkgname}/register.sh
+ install -m744 unregister.sh ${pkgdir}/usr/share/haskell/${pkgname}/unregister.sh
+ install -d -m755 ${pkgdir}/usr/share/doc/ghc/html/libraries
+ ln -s /usr/share/doc/${pkgname}/html ${pkgdir}/usr/share/doc/ghc/html/libraries/${_hkgname}
+ runhaskell Setup copy --destdir=${pkgdir}
+ install -D -m644 LICENSE ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
+ rm -f ${pkgdir}/usr/share/doc/${pkgname}/LICENSE
+}
+md5sums=('42de2a6c847169c693e0ba2282c91432')
diff --git a/haskell-chp.install b/haskell-chp.install
new file mode 100644
index 000000000000..edae86a0731b
--- /dev/null
+++ b/haskell-chp.install
@@ -0,0 +1,18 @@
+HS_DIR=usr/share/haskell/haskell-chp
+post_install() {
+ ${HS_DIR}/register.sh
+ (cd usr/share/doc/ghc/html/libraries; ./gen_contents_index)
+}
+pre_upgrade() {
+ ${HS_DIR}/unregister.sh
+}
+post_upgrade() {
+ ${HS_DIR}/register.sh
+ (cd usr/share/doc/ghc/html/libraries; ./gen_contents_index)
+}
+pre_remove() {
+ ${HS_DIR}/unregister.sh
+}
+post_remove() {
+ (cd usr/share/doc/ghc/html/libraries; ./gen_contents_index)
+}