summarylogtreecommitdiffstats
diff options
context:
space:
mode:
author71e6fd522020-02-29 13:03:27 +0800
committer71e6fd522020-02-29 13:03:27 +0800
commit4734fcdf0dc234a6ae5d0c30392db4d45a7e78fc (patch)
tree3262fa47efd13fb21cfc058811ddb5852c3172f7
downloadaur-haskell-deque.tar.gz
0.4.3
-rw-r--r--.SRCINFO23
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD42
3 files changed, 68 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7370752ede85
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = haskell-deque
+ pkgdesc = Double-ended queues
+ pkgver = 0.4.3
+ pkgrel = 1
+ url = https://hackage.haskell.org/package/deque
+ arch = x86_64
+ license = MIT
+ makedepends = ghc
+ depends = ghc-libs
+ depends = haskell-hashable
+ depends = haskell-mtl
+ depends = haskell-strict-list
+ depends = haskell-quickcheck
+ depends = haskell-quickcheck-instances
+ depends = haskell-rerebase
+ depends = haskell-tasty
+ depends = haskell-tasty-hunit
+ depends = haskell-tasty-quickcheck
+ source = https://hackage.haskell.org/packages/archive/deque/0.4.3/deque-0.4.3.tar.gz
+ sha512sums = 640e46766c443f1fac3819ace611f762f78613c457a0aeaed7cc439f0c9e41f5126d06dec7867bc3d2b0ddc3fc030dda3e30a3b01c79cce65142e884987f21cd
+
+pkgname = haskell-deque
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..8e8409730516
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+*
+!.*
+!PKGBUILD
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b4c204e3ccab
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: 71e6fd52 <71e6fd52 at gmail dot com>
+
+_hkgname=deque
+pkgname=haskell-deque
+pkgver=0.4.3
+pkgrel=1
+pkgdesc='Double-ended queues'
+url='https://hackage.haskell.org/package/deque'
+license=('MIT')
+arch=('x86_64')
+depends=('ghc-libs' 'haskell-hashable' 'haskell-mtl' 'haskell-strict-list' 'haskell-quickcheck' 'haskell-quickcheck-instances' 'haskell-rerebase' 'haskell-tasty' 'haskell-tasty-hunit' 'haskell-tasty-quickcheck')
+makedepends=('ghc')
+source=("https://hackage.haskell.org/packages/archive/${_hkgname}/${pkgver}/${_hkgname}-${pkgver}.tar.gz")
+sha512sums=('640e46766c443f1fac3819ace611f762f78613c457a0aeaed7cc439f0c9e41f5126d06dec7867bc3d2b0ddc3fc030dda3e30a3b01c79cce65142e884987f21cd')
+
+build() {
+ cd $_hkgname-$pkgver
+
+ runhaskell Setup configure -O --enable-shared --enable-executable-dynamic --disable-library-vanilla \
+ --prefix=/usr --docdir=/usr/share/doc/$pkgname --enable-tests \
+ --dynlibdir=/usr/lib --libsubdir=\$compiler/site-local/\$pkgid
+ runhaskell Setup build
+ runhaskell Setup register --gen-script
+ runhaskell Setup unregister --gen-script
+ sed -i -r -e "s|ghc-pkg.*update[^ ]* |&'--force' |" register.sh
+ sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
+}
+
+check() {
+ cd $_hkgname-$pkgver
+ runhaskell Setup test
+}
+
+package() {
+ cd $_hkgname-$pkgver
+
+ install -D -m744 register.sh "$pkgdir"/usr/share/haskell/register/$pkgname.sh
+ install -D -m744 unregister.sh "$pkgdir"/usr/share/haskell/unregister/$pkgname.sh
+ runhaskell Setup copy --destdir="$pkgdir"
+ install -D -m644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+ rm -f "$pkgdir"/usr/share/doc/$pkgname/LICENSE
+}