summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJaron Kent-Dobias2019-02-06 09:29:55 -0500
committerJaron Kent-Dobias2019-02-06 09:29:55 -0500
commit6687a867c93aa8e7fed0c4c7015a625414230fbb (patch)
tree3f0b1c27b93386b6b1d1525385f14cdd8185d688
downloadaur-haskell-groups.tar.gz
initialized repo
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD39
2 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f0c0d08c36c5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = haskell-groups
+ pkgdesc = A monoid with invertibility.
+ pkgver = 0.4.1.0
+ pkgrel = 1
+ url = https://hackage.haskell.org/package/groups
+ arch = x86_64
+ license = BSD-3
+ makedepends = ghc
+ depends = ghc-libs
+ source = https://hackage.haskell.org/package/groups-0.4.1.0/groups-0.4.1.0.tar.gz
+ sha512sums = 35ea37843d26803b0e1b5c515c8117992faee5d891df29b08df29977443547193855a44b198fe632ee5216135d342192072e112ae598ade55dd3bca5cb595927
+
+pkgname = haskell-groups
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..97a3a5e58e21
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Jaron Kent-Dobias <jaron@kent-dobias.com>
+
+_hkgname=groups
+pkgname=haskell-groups
+pkgver=0.4.1.0
+pkgrel=1
+pkgdesc='A monoid with invertibility.'
+url='https://hackage.haskell.org/package/groups'
+license=('BSD-3')
+arch=('x86_64')
+depends=('ghc-libs')
+makedepends=('ghc')
+source=(https://hackage.haskell.org/package/${_hkgname}-${pkgver}/${_hkgname}-${pkgver}.tar.gz)
+sha512sums=('35ea37843d26803b0e1b5c515c8117992faee5d891df29b08df29977443547193855a44b198fe632ee5216135d342192072e112ae598ade55dd3bca5cb595927')
+
+build() {
+ cd ${_hkgname}-${pkgver}
+ runhaskell Setup configure -O --enable-shared --enable-executable-dynamic --disable-library-vanilla \
+ --prefix=/usr --docdir=/usr/share/doc/$pkgname \
+ --dynlibdir=/usr/lib --libsubdir=\$compiler/site-local/\$pkgid
+ runhaskell Setup build
+ runhaskell Setup haddock
+ runhaskell Setup register --gen-script
+ runhaskell Setup unregister --gen-script
+ sed -i -r -e "s|ghc-pkg.*update[^ ]* |&'--force' |" register.sh
+ sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
+}
+
+package() {
+ cd ${_hkgname}-${pkgver}
+ install -Dm 744 register.sh "${pkgdir}/usr/share/haskell/register/${pkgname}.sh"
+ install -Dm 744 unregister.sh "${pkgdir}/usr/share/haskell/unregister/${pkgname}.sh"
+ install -dm 755 "${pkgdir}/usr/share/doc/ghc/html/libraries"
+ runhaskell Setup copy --destdir="$pkgdir"
+ install -Dm 644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
+ ln -s /usr/share/doc/${pkgname}/html "${pkgdir}/usr/share/doc/ghc/html/libraries/${_hkgname}"
+}
+
+# vim: ts=2 sw=2 et: