summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEmanuel Amaral Couto2017-12-27 16:09:24 +0000
committerEmanuel Amaral Couto2017-12-27 16:09:24 +0000
commit1e660a43edb7125514410a98e1c6f64c57f49116 (patch)
tree5ad25e666e7942f30e1d88571b04df898d151f61
downloadaur-haskell-helm-git.tar.gz
Initial commit
-rw-r--r--.SRCINFO26
-rw-r--r--PKGBUILD46
2 files changed, 72 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2dd261b341fc
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,26 @@
+pkgbase = haskell-helm-git
+ pkgdesc = A functionally reactive game engine
+ pkgver = r283.e2d8745
+ pkgrel = 1
+ url = http://github.com/switchface/helm
+ arch = i686
+ arch = x86_64
+ license = custom:BSD3
+ makedepends = ghc
+ depends = ghc-libs
+ depends = haskell-cairo
+ depends = haskell-elerea
+ depends = haskell-linear
+ depends = haskell-mtl
+ depends = haskell-pango
+ depends = haskell-random
+ depends = haskell-sdl2
+ depends = haskell-stm
+ depends = haskell-text
+ provides = haskell-helm
+ conflicts = haskell-helm
+ source = haskell-helm-git::git+https://github.com/z0w0/helm.git
+ sha512sums = SKIP
+
+pkgname = haskell-helm-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..23f6bedebcaf
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,46 @@
+# $Id$
+# Maintainer: Emanuel Couto <unit73e at gmail dot com>
+
+_hkgname=helm
+pkgname=haskell-helm-git
+pkgver=r283.e2d8745
+pkgrel=1
+pkgdesc="A functionally reactive game engine"
+url="http://github.com/switchface/helm"
+license=('custom:BSD3')
+arch=('i686' 'x86_64')
+depends=('ghc-libs' 'haskell-cairo' 'haskell-elerea' 'haskell-linear' 'haskell-mtl'
+ 'haskell-pango' 'haskell-random' 'haskell-sdl2' 'haskell-stm' 'haskell-text')
+makedepends=('ghc')
+conflicts=('haskell-helm')
+provides=('haskell-helm')
+source=("${pkgname}::git+https://github.com/z0w0/helm.git")
+sha512sums=('SKIP')
+
+pkgver() {
+ cd "$pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "${srcdir}/${pkgname}"
+
+ runhaskell Setup configure -O --enable-shared --enable-executable-dynamic --disable-library-vanilla \
+ --prefix=/usr --docdir="/usr/share/doc/${pkgname}" \
+ --dynlibdir=/usr/lib --libsubdir=\$compiler/site-local/\$pkgid
+ runhaskell Setup build
+ runhaskell Setup register --gen-script
+ runhaskell Setup unregister --gen-script
+ sed -i -r -e "s|ghc-pkg.*update[^ ]* |&'--force' |" register.sh
+ sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
+}
+
+package() {
+ cd "${srcdir}/${pkgname}"
+
+ install -D -m744 register.sh "${pkgdir}/usr/share/haskell/register/${pkgname}.sh"
+ install -D -m744 unregister.sh "${pkgdir}/usr/share/haskell/unregister/${pkgname}.sh"
+ runhaskell Setup copy --destdir="${pkgdir}"
+ install -D -m644 "LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ rm -f "${pkgdir}/usr/share/doc/${pkgname}/LICENSE"
+}