summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichał Wojdyła2023-06-27 20:20:10 +0200
committerMichał Wojdyła2023-06-27 20:20:10 +0200
commite2f420c3df1990ec1aa1f9c0f9a48cc419583646 (patch)
tree2623562ed60307398041d45d5c01c8922ba6379e
parent176193bd88557e402577666ca20d429cd1cd0560 (diff)
downloadaur-haskell-http-reverse-proxy.tar.gz
update to 0.6.0.1
-rw-r--r--.SRCINFO38
-rw-r--r--PKGBUILD37
-rw-r--r--haskell-http-reverse-proxy.install18
3 files changed, 32 insertions, 61 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9ac313560173..cceca0c0cb48 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,37 +1,23 @@
-# Generated by mksrcinfo v8
-# Wed Dec 23 09:01:29 UTC 2015
pkgbase = haskell-http-reverse-proxy
pkgdesc = Reverse proxy HTTP requests, either over raw sockets or with WAI
- pkgver = 0.4.3
+ pkgver = 0.6.0.1
pkgrel = 1
url = http://hackage.haskell.org/package/http-reverse-proxy
- install = haskell-http-reverse-proxy.install
arch = i686
arch = x86_64
license = custom:BSD3
- depends = ghc
- depends = haskell-async
- depends = haskell-blaze-builder>=0.3
- depends = haskell-bytestring
- depends = haskell-case-insensitive>=0.4
- depends = haskell-conduit>=1.1
+ makedepends = ghc
+ depends = ghc-libs
+ depends = haskell-blaze-builder
+ depends = haskell-case-insensitive
+ depends = haskell-conduit
depends = haskell-conduit-extra
- depends = haskell-containers
- depends = haskell-data-default-class
- depends = haskell-http-client>=0.3
- depends = haskell-http-types>=0.6
- depends = haskell-lifted-base>=0.1
- depends = haskell-monad-control>=0.3
- depends = haskell-network
- depends = haskell-resourcet
- depends = haskell-streaming-commons
- depends = haskell-text
- depends = haskell-transformers
- depends = haskell-wai>=3.0
+ depends = haskell-http-client
+ depends = haskell-unliftio
+ depends = haskell-wai
depends = haskell-wai-logger
- depends = haskell-word8>=0.0
- source = http://hackage.haskell.org/packages/archive/http-reverse-proxy/0.4.3/http-reverse-proxy-0.4.3.tar.gz
- md5sums = 6b591e99ac61f29de4ed9544f68e9211
+ depends = haskell-word8
+ source = http://hackage.haskell.org/packages/archive/http-reverse-proxy/0.6.0.1/http-reverse-proxy-0.6.0.1.tar.gz
+ md5sums = d115fc1e2e0a8b1626d0ec7ed15fd140
pkgname = haskell-http-reverse-proxy
-
diff --git a/PKGBUILD b/PKGBUILD
index bda0bb35d409..25f477fb8def 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,33 +1,36 @@
-# Maintainer: Leif Warner <abimelech@gmail.com>
+# Contributor: Leif Warner <abimelech@gmail.com>
_hkgname=http-reverse-proxy
pkgname=haskell-http-reverse-proxy
-pkgver=0.4.3
+pkgver=0.6.0.1
pkgrel=1
pkgdesc="Reverse proxy HTTP requests, either over raw sockets or with WAI"
url="http://hackage.haskell.org/package/${_hkgname}"
license=('custom:BSD3')
arch=('i686' 'x86_64')
-depends=('ghc' 'haskell-async' 'haskell-blaze-builder>=0.3' 'haskell-bytestring' 'haskell-case-insensitive>=0.4' 'haskell-conduit>=1.1' 'haskell-conduit-extra' 'haskell-containers' 'haskell-data-default-class' 'haskell-http-client>=0.3' 'haskell-http-types>=0.6' 'haskell-lifted-base>=0.1' 'haskell-monad-control>=0.3' 'haskell-network' 'haskell-resourcet' 'haskell-streaming-commons' 'haskell-text' 'haskell-transformers' 'haskell-wai>=3.0' 'haskell-wai-logger' 'haskell-word8>=0.0')
+depends=('ghc-libs' 'haskell-blaze-builder' 'haskell-case-insensitive' 'haskell-conduit' 'haskell-conduit-extra' 'haskell-http-client' 'haskell-unliftio' 'haskell-wai' 'haskell-wai-logger' 'haskell-word8')
+makedepends=('ghc')
source=(http://hackage.haskell.org/packages/archive/${_hkgname}/${pkgver}/${_hkgname}-${pkgver}.tar.gz)
-install=${pkgname}.install
-md5sums=('6b591e99ac61f29de4ed9544f68e9211')
+md5sums=('d115fc1e2e0a8b1626d0ec7ed15fd140')
build() {
- cd ${srcdir}/${_hkgname}-${pkgver}
- runhaskell Setup configure -O ${PKGBUILD_HASKELL_ENABLE_PROFILING:+-p } --enable-split-objs --enable-shared \
- --prefix=/usr --docdir=/usr/share/doc/${pkgname} --libsubdir=\$compiler/site-local/\$pkgid
+ cd "${srcdir}/${_hkgname}-${pkgver}"
+ runhaskell Setup configure -O --enable-shared --enable-executable-dynamic --disable-library-vanilla \
+ --prefix=/usr --docdir="/usr/share/doc/${pkgname}" --datasubdir="$pkgname" \
+ --dynlibdir=/usr/lib --libsubdir=\$compiler/site-local/\$pkgid
runhaskell Setup build
runhaskell Setup haddock
- runhaskell Setup register --gen-script
+ runhaskell Setup register --gen-script
runhaskell Setup unregister --gen-script
+ sed -i -r -e "s|ghc-pkg.*update[^ ]* |&'--force' |" register.sh
sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
}
+
package() {
- cd ${srcdir}/${_hkgname}-${pkgver}
- install -D -m744 register.sh ${pkgdir}/usr/share/haskell/${pkgname}/register.sh
- install -m744 unregister.sh ${pkgdir}/usr/share/haskell/${pkgname}/unregister.sh
- install -d -m755 ${pkgdir}/usr/share/doc/ghc/html/libraries
- ln -s /usr/share/doc/${pkgname}/html ${pkgdir}/usr/share/doc/ghc/html/libraries/${_hkgname}
- runhaskell Setup copy --destdir=${pkgdir}
- install -D -m644 LICENSE ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
- rm -f ${pkgdir}/usr/share/doc/${pkgname}/LICENSE
+ cd ${_hkgname}-${pkgver}
+ install -D -m744 register.sh "${pkgdir}/usr/share/haskell/register/${pkgname}.sh"
+ install -D -m744 unregister.sh "${pkgdir}/usr/share/haskell/unregister/${pkgname}.sh"
+ install -d -m755 "${pkgdir}/usr/share/doc/ghc/html/libraries"
+ ln -s /usr/share/doc/${pkgname}/html "${pkgdir}/usr/share/doc/ghc/html/libraries/${_hkgname}"
+ runhaskell Setup copy --destdir="${pkgdir}"
+ install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ rm -f "${pkgdir}/usr/share/doc/${pkgname}/LICENSE"
}
diff --git a/haskell-http-reverse-proxy.install b/haskell-http-reverse-proxy.install
deleted file mode 100644
index b132de28068c..000000000000
--- a/haskell-http-reverse-proxy.install
+++ /dev/null
@@ -1,18 +0,0 @@
-HS_DIR=usr/share/haskell/haskell-http-reverse-proxy
-post_install() {
- ${HS_DIR}/register.sh
- (cd usr/share/doc/ghc/html/libraries; ./gen_contents_index)
-}
-pre_upgrade() {
- ${HS_DIR}/unregister.sh
-}
-post_upgrade() {
- ${HS_DIR}/register.sh
- (cd usr/share/doc/ghc/html/libraries; ./gen_contents_index)
-}
-pre_remove() {
- ${HS_DIR}/unregister.sh
-}
-post_remove() {
- (cd usr/share/doc/ghc/html/libraries; ./gen_contents_index)
-}