summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJakob Gruber2015-06-21 23:22:48 +0200
committerJakob Gruber2015-06-21 23:24:59 +0200
commit185c3f782318c524b08bde4f4b49761761f0bb8d (patch)
tree8793809d18243efa5a4b0d197f2ebe91a3834777
downloadaur-haskell-hunit.tar.gz
Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD37
-rw-r--r--haskell-hunit.install18
3 files changed, 71 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5b900fe5a1e8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = haskell-hunit
+ pkgdesc = A unit testing framework for Haskell
+ pkgver = 1.2.5.2
+ pkgrel = 1
+ url = http://hackage.haskell.org/package/HUnit
+ install = haskell-hunit.install
+ arch = i686
+ arch = x86_64
+ license = custom:BSD3
+ depends = ghc
+ options = strip
+ source = http://hackage.haskell.org/packages/archive/HUnit/1.2.5.2/HUnit-1.2.5.2.tar.gz
+ md5sums = 1ba79aaeb57361a8593e864694539025
+
+pkgname = haskell-hunit
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..dd19fdf23f68
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: schuay <jakob.gruber@gmail.com>
+
+_hkgname=HUnit
+pkgname=haskell-hunit
+pkgver=1.2.5.2
+pkgrel=1
+pkgdesc="A unit testing framework for Haskell"
+url="http://hackage.haskell.org/package/${_hkgname}"
+license=('custom:BSD3')
+arch=('i686' 'x86_64')
+depends=('ghc')
+options=('strip')
+source=(http://hackage.haskell.org/packages/archive/${_hkgname}/${pkgver}/${_hkgname}-${pkgver}.tar.gz)
+install=${pkgname}.install
+
+build() {
+ cd ${srcdir}/${_hkgname}-${pkgver}
+ runhaskell Setup configure -O ${PKGBUILD_HASKELL_ENABLE_PROFILING:+-p } --enable-split-objs --enable-shared \
+ --prefix=/usr --docdir=/usr/share/doc/${pkgname} --libsubdir=\$compiler/site-local/\$pkgid
+ runhaskell Setup build
+ runhaskell Setup haddock
+ runhaskell Setup register --gen-script
+ runhaskell Setup unregister --gen-script
+ sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
+}
+package() {
+ cd ${srcdir}/${_hkgname}-${pkgver}
+ install -D -m744 register.sh ${pkgdir}/usr/share/haskell/${pkgname}/register.sh
+ install -m744 unregister.sh ${pkgdir}/usr/share/haskell/${pkgname}/unregister.sh
+ install -d -m755 ${pkgdir}/usr/share/doc/ghc/html/libraries
+ ln -s /usr/share/doc/${pkgname}/html ${pkgdir}/usr/share/doc/ghc/html/libraries/${_hkgname}
+ runhaskell Setup copy --destdir=${pkgdir}
+ install -D -m644 LICENSE ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
+ rm -f ${pkgdir}/usr/share/doc/${pkgname}/LICENSE
+}
+
+md5sums=('1ba79aaeb57361a8593e864694539025')
diff --git a/haskell-hunit.install b/haskell-hunit.install
new file mode 100644
index 000000000000..0c6e68b7242c
--- /dev/null
+++ b/haskell-hunit.install
@@ -0,0 +1,18 @@
+HS_DIR=usr/share/haskell/haskell-hunit
+post_install() {
+ ${HS_DIR}/register.sh
+ (cd usr/share/doc/ghc/html/libraries; ./gen_contents_index)
+}
+pre_upgrade() {
+ ${HS_DIR}/unregister.sh
+}
+post_upgrade() {
+ ${HS_DIR}/register.sh
+ (cd usr/share/doc/ghc/html/libraries; ./gen_contents_index)
+}
+pre_remove() {
+ ${HS_DIR}/unregister.sh
+}
+post_remove() {
+ (cd usr/share/doc/ghc/html/libraries; ./gen_contents_index)
+}