summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Nagy2015-06-08 20:30:13 +0200
committerDaniel Nagy2015-06-08 20:30:13 +0200
commitb5be5724a473a5ae4ef82818574e5e2515fe7675 (patch)
tree36905338dfc6bd64de57789a7ef4bc9d7992a0ee
downloadaur-haskell-lifted-base.tar.gz
import to aur4
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD41
-rw-r--r--haskell-lifted-base.install26
3 files changed, 87 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b266765ddafd
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = haskell-lifted-base
+ pkgdesc = lifted-base exports IO operations from the base library lifted to any instance of MonadBase or MonadBaseControl.
+ pkgver = 0.2.3.6
+ pkgrel = 2
+ url = http://hackage.haskell.org/package/lifted-base
+ install = haskell-lifted-base.install
+ arch = i686
+ arch = x86_64
+ license = BSD3
+ depends = ghc
+ depends = haskell-base-unicode-symbols
+ depends = haskell-monad-control
+ depends = haskell-transformers-base
+ options = strip
+ options = staticlibs
+ source = http://hackage.haskell.org/packages/archive/lifted-base/0.2.3.6/lifted-base-0.2.3.6.tar.gz
+ sha256sums = 57c5837d83f569bb72136ca89256e50e1ac168ee935804a8e7763e9d8322e1fb
+
+pkgname = haskell-lifted-base
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..37e775c71bd5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer: Daniel Nagy <danielnagy at gmx de>
+# Contributor: Lex Black <autumn-wind at web dot de>
+
+pkgname=haskell-lifted-base
+_hkgname=lifted-base
+_licensefile=LICENSE
+pkgver=0.2.3.6
+pkgrel=2
+pkgdesc="lifted-base exports IO operations from the base library lifted to any instance of MonadBase or MonadBaseControl."
+url="http://hackage.haskell.org/package/lifted-base"
+license=('BSD3')
+arch=('i686' 'x86_64')
+depends=( 'ghc' 'haskell-base-unicode-symbols' 'haskell-monad-control' 'haskell-transformers-base')
+options=('strip' 'staticlibs' )
+source=("http://hackage.haskell.org/packages/archive/${_hkgname}/${pkgver}/${_hkgname}-${pkgver}.tar.gz")
+install="${pkgname}.install"
+sha256sums=('57c5837d83f569bb72136ca89256e50e1ac168ee935804a8e7763e9d8322e1fb')
+
+build() {
+ cd ${srcdir}/${_hkgname}-${pkgver}
+
+ runhaskell Setup configure -O ${PKGBUILD_HASKELL_ENABLE_PROFILING:+-p } --enable-split-objs --enable-shared \
+ --prefix=/usr --docdir=/usr/share/doc/${pkgname} \
+ --libsubdir=\$compiler/site-local/\$pkgid
+ runhaskell Setup build
+ runhaskell Setup haddock
+ runhaskell Setup register --gen-script
+ runhaskell Setup unregister --gen-script
+ sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
+}
+
+package() {
+ cd ${srcdir}/${_hkgname}-${pkgver}
+ install -D -m744 register.sh ${pkgdir}/usr/share/haskell/${pkgname}/register.sh
+ install -m744 unregister.sh ${pkgdir}/usr/share/haskell/${pkgname}/unregister.sh
+ install -d -m755 ${pkgdir}/usr/share/doc/ghc/html/libraries
+ ln -s /usr/share/doc/${pkgname}/html ${pkgdir}/usr/share/doc/ghc/html/libraries/${_hkgname}
+ runhaskell Setup copy --destdir=${pkgdir}
+ install -D -m644 ${_licensefile} ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
+ rm -f ${pkgdir}/usr/share/doc/${pkgname}/${_licensefile}
+}
diff --git a/haskell-lifted-base.install b/haskell-lifted-base.install
new file mode 100644
index 000000000000..1f88d050f45e
--- /dev/null
+++ b/haskell-lifted-base.install
@@ -0,0 +1,26 @@
+# custom variables
+pkgname=haskell-lifted-base
+HS_DIR=usr/share/haskell/${pkgname}
+
+# functions
+post_install() {
+ ${HS_DIR}/register.sh
+ (cd usr/share/doc/ghc/html/libraries; ./gen_contents_index)
+}
+
+pre_upgrade() {
+ ${HS_DIR}/unregister.sh
+}
+
+post_upgrade() {
+ ${HS_DIR}/register.sh
+ (cd usr/share/doc/ghc/html/libraries; ./gen_contents_index)
+}
+
+pre_remove() {
+ ${HS_DIR}/unregister.sh
+}
+
+post_remove() {
+ (cd usr/share/doc/ghc/html/libraries; ./gen_contents_index)
+}