summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Nagy2015-06-08 20:32:14 +0200
committerDaniel Nagy2015-06-08 20:32:14 +0200
commit34d20fa679d4739f1014782b0f4a6fa1e1dfe18c (patch)
treea47a3449c07d33acf3e3290b320f851d024daf0b
downloadaur-haskell-wl-pprint.tar.gz
import to aur4
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD37
-rw-r--r--haskell-wl-pprint.install18
3 files changed, 71 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..04c55c63df72
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = haskell-wl-pprint
+ pkgdesc = The Wadler/Leijen Pretty Printer
+ pkgver = 1.1
+ pkgrel = 1
+ url = http://hackage.haskell.org/package/wl-pprint
+ install = haskell-wl-pprint.install
+ arch = i686
+ arch = x86_64
+ license = custom:BSD3
+ depends = ghc
+ options = strip
+ source = http://hackage.haskell.org/packages/archive/wl-pprint/1.1/wl-pprint-1.1.tar.gz
+ md5sums = 5cb236328bc95d9fb1ac306732bd6900
+
+pkgname = haskell-wl-pprint
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..308f1b29f936
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Daniel Nagy <danielnagy at gmx de>
+# Contributor: lilydjwg <lilydjwg@gmail.com>
+
+_hkgname=wl-pprint
+pkgname=haskell-wl-pprint
+pkgver=1.1
+pkgrel=1
+pkgdesc="The Wadler/Leijen Pretty Printer"
+url="http://hackage.haskell.org/package/${_hkgname}"
+license=('custom:BSD3')
+arch=('i686' 'x86_64')
+makedepends=()
+depends=('ghc')
+options=('strip')
+source=(http://hackage.haskell.org/packages/archive/${_hkgname}/${pkgver}/${_hkgname}-${pkgver}.tar.gz)
+install=${pkgname}.install
+md5sums=('5cb236328bc95d9fb1ac306732bd6900')
+build() {
+ cd ${srcdir}/${_hkgname}-${pkgver}
+ runhaskell Setup configure -O ${PKGBUILD_HASKELL_ENABLE_PROFILING:+-p } --enable-split-objs --enable-shared \
+ --prefix=/usr --docdir=/usr/share/doc/${pkgname} --libsubdir=\$compiler/site-local/\$pkgid
+ runhaskell Setup build
+ runhaskell Setup haddock
+ runhaskell Setup register --gen-script
+ runhaskell Setup unregister --gen-script
+ sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
+}
+package() {
+ cd ${srcdir}/${_hkgname}-${pkgver}
+ install -D -m744 register.sh ${pkgdir}/usr/share/haskell/${pkgname}/register.sh
+ install -m744 unregister.sh ${pkgdir}/usr/share/haskell/${pkgname}/unregister.sh
+ install -d -m755 ${pkgdir}/usr/share/doc/ghc/html/libraries
+ ln -s /usr/share/doc/${pkgname}/html ${pkgdir}/usr/share/doc/ghc/html/libraries/${_hkgname}
+ runhaskell Setup copy --destdir=${pkgdir}
+ install -D -m644 LICENSE ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
+ rm -f ${pkgdir}/usr/share/doc/${pkgname}/LICENSE
+}
diff --git a/haskell-wl-pprint.install b/haskell-wl-pprint.install
new file mode 100644
index 000000000000..0d90012b7663
--- /dev/null
+++ b/haskell-wl-pprint.install
@@ -0,0 +1,18 @@
+HS_DIR=usr/share/haskell/haskell-wl-pprint
+post_install() {
+ ${HS_DIR}/register.sh
+ (cd usr/share/doc/ghc/html/libraries; ./gen_contents_index)
+}
+pre_upgrade() {
+ ${HS_DIR}/unregister.sh
+}
+post_upgrade() {
+ ${HS_DIR}/register.sh
+ (cd usr/share/doc/ghc/html/libraries; ./gen_contents_index)
+}
+pre_remove() {
+ ${HS_DIR}/unregister.sh
+}
+post_remove() {
+ (cd usr/share/doc/ghc/html/libraries; ./gen_contents_index)
+}