summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAshley Bone2023-12-10 16:18:22 -0500
committerAshley Bone2023-12-10 16:18:22 -0500
commit0f239b6560483b6a74d516b149f72425a1c87b89 (patch)
tree961cc569ba74091e73f00207702fedf29fc70391
parentb6f8a7adb8877c2215f5adceafd6aedc77b27294 (diff)
downloadaur-healthchecks.tar.gz
Upgrade to 3.0.1.
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD15
2 files changed, 11 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 358c0a7f2fca..d0073b71450d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = healthchecks
pkgdesc = A cron monitoring service with a web-based dashboard, API, and notification integrations.
- pkgver = 2.10.0
+ pkgver = 3.0.1
pkgrel = 1
url = https://github.com/healthchecks/healthchecks
install = healthchecks.install
@@ -11,10 +11,12 @@ pkgbase = healthchecks
depends = python-cronsim
depends = python-django
depends = python-django-compressor
+ depends = python-django-stubs-ext
depends = python-fido2
depends = python-pyotp
depends = python-pytz
depends = python-pycurl
+ depends = python-pydantic
depends = python-segno
depends = python-statsd
depends = python-whitenoise
@@ -24,7 +26,7 @@ pkgbase = healthchecks
optdepends = python-apprise: Add support for the Apprise integration.
backup = var/lib/healthchecks/local_settings.py
backup = etc/uwsgi/healthchecks.ini
- source = https://github.com/healthchecks/healthchecks/archive/refs/tags/v2.10.tar.gz
+ source = https://github.com/healthchecks/healthchecks/archive/refs/tags/v3.0.1.tar.gz
source = hc-clean-db
source = hc-manage
source = healthchecks-clean-db.service
@@ -36,7 +38,7 @@ pkgbase = healthchecks
source = healthchecks.tmpfiles
source = local_settings.py
source = settings.patch
- sha256sums = b5eab3aad426aad47380b9a34287a0495c00037c50c6a7d09cadf83019f717f0
+ sha256sums = b6a567e59d6a3e1916882fa39794c9cfceb3c1ee6135464f604adc35d64d4b82
sha256sums = a7b75bdd35c6952e06e1cd3824450f7c613aff5e3fb1d9f4f57f517b57cefbde
sha256sums = 355ac237284642e24a3cbe7ddb285bf7dbb802e72ea7fe7c68f0476178ab94fc
sha256sums = 9d32c4d1404079cac9b7a4ccbc97e01d867735c2536f915220d2ac5dffc333e7
diff --git a/PKGBUILD b/PKGBUILD
index b583f39b28f1..acd41fded7d4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,21 @@
# Maintainer: Ashley Bone <ashley DOT bone AT pm DOT me>
pkgname=healthchecks
-_pkgver=2.10
-pkgver=2.10.0
+_pkgver=3.0.1
+pkgver=3.0.1
pkgrel=1
pkgdesc="A cron monitoring service with a web-based dashboard, API, and notification integrations."
arch=('any')
url="https://github.com/healthchecks/healthchecks"
license=('BSD')
depends=('python-aiosmtpd' 'python-cron-descriptor' 'python-cronsim' 'python-django'
- 'python-django-compressor' 'python-fido2' 'python-pyotp' 'python-pytz' 'python-pycurl'
- 'python-segno' 'python-statsd' 'python-whitenoise' 'uwsgi' 'uwsgi-plugin-python')
+ 'python-django-compressor' 'python-django-stubs-ext' 'python-fido2' 'python-pyotp'
+ 'python-pytz' 'python-pycurl' 'python-pydantic' 'python-segno' 'python-statsd' 'python-whitenoise'
+ 'uwsgi' 'uwsgi-plugin-python')
optdepends=('python-psycopg2: Add support for postgreSQL.'
'python-apprise: Add support for the Apprise integration.')
backup=("var/lib/$pkgname/local_settings.py" "etc/uwsgi/$pkgname.ini")
install="$pkgname.install"
-
-# other ways of specifying source from github:
-# source=("git+$url#tag=v$pkgver")
-# source=('project_name::git+https://project_url#branch=project_branch')
source=("$url/archive/refs/tags/v$_pkgver.tar.gz"
"hc-clean-db"
"hc-manage"
@@ -31,7 +28,7 @@ source=("$url/archive/refs/tags/v$_pkgver.tar.gz"
"$pkgname.tmpfiles"
"local_settings.py"
"settings.patch")
-sha256sums=('b5eab3aad426aad47380b9a34287a0495c00037c50c6a7d09cadf83019f717f0'
+sha256sums=('b6a567e59d6a3e1916882fa39794c9cfceb3c1ee6135464f604adc35d64d4b82'
'a7b75bdd35c6952e06e1cd3824450f7c613aff5e3fb1d9f4f57f517b57cefbde'
'355ac237284642e24a3cbe7ddb285bf7dbb802e72ea7fe7c68f0476178ab94fc'
'9d32c4d1404079cac9b7a4ccbc97e01d867735c2536f915220d2ac5dffc333e7'