summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052024-04-19 16:19:15 +0800
committerzxp198210052024-04-19 16:19:15 +0800
commitf3811bed584eac55c714722bd29ef15d5b36e748 (patch)
treeb62f6d0715656514d39c4a46a428f36a619012e6
parent37339c6ce4ffb71ffafcbddb6601ef439ef10cc0 (diff)
downloadaur-helio-workstation-bin.tar.gz
update to 3.12
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD54
2 files changed, 42 insertions, 27 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f8ac8b535826..a467081ab43e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,17 @@
pkgbase = helio-workstation-bin
- pkgdesc = Helio is free and cross-platform lightweight music creation playground.
- pkgver = 3.11
+ pkgdesc = A free and open-source music sequencer for desktop and mobile platforms
+ pkgver = 3.12
pkgrel = 1
url = https://helio.fm/
arch = x86_64
- license = GPL3
+ license = GPL-3.0-only
depends = libcurl-gnutls
+ depends = alsa-lib
+ depends = libglvnd
+ provides = helio-workstation=3.12
+ conflicts = helio-workstation
options = !strip
- options = !emptydirs
- source = https://ci.helio.fm/helio-3.11-x64.deb
- sha512sums = 1ba99a39b3b8a5afe57ed5f965df1fd0e03ef4ee20f181c64f3c8163e24220448988b076135459197bd9d670241ebce6e55dcd5d959b17285553c8216979203e
+ source = helio-workstation-3.12.deb::https://ci.helio.fm/helio-3.12-x64.deb
+ sha256sums = 65f02cd4c926e1b4419edc429660bd3848dcfcbdd914b4c4dbb44a189d52f872
pkgname = helio-workstation-bin
diff --git a/PKGBUILD b/PKGBUILD
index a05b949a77af..d4d3ac5dadc9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,38 @@
-# Maintainer: Gyara <laxect39@gmail.com>
-
-pkgname=helio-workstation-bin
-pkgver=3.11
+# Maintainer: zxp19821005 <zxp19821005 at 163 dot com>
+# Contributor: Gyara <laxect39@gmail.com>
+_pkgname=helio
+pkgname="${_pkgname}-workstation-bin"
+_appname=Helio
+pkgver=3.12
pkgrel=1
-pkgdesc="Helio is free and cross-platform lightweight music creation playground."
+pkgdesc="A free and open-source music sequencer for desktop and mobile platforms"
arch=('x86_64')
url="https://helio.fm/"
-license=('GPL3')
-depends=('libcurl-gnutls')
-options=('!strip' '!emptydirs')
-source=("https://ci.helio.fm/helio-${pkgver}-x64.deb")
-sha512sums=('1ba99a39b3b8a5afe57ed5f965df1fd0e03ef4ee20f181c64f3c8163e24220448988b076135459197bd9d670241ebce6e55dcd5d959b17285553c8216979203e')
-
+_ghurl="https://github.com/helio-fm/helio-sequencer"
+license=('GPL-3.0-only')
+provides=("${pkgname%-bin}=${pkgver}")
+conflicts=("${pkgname%-bin}")
+depends=(
+ 'libcurl-gnutls'
+ 'alsa-lib'
+ 'libglvnd'
+)
+options=(
+ '!strip'
+)
+source=(
+ "${pkgname%-bin}-${pkgver}.deb::https://ci.helio.fm/${_pkgname}-${pkgver}-x64.deb"
+)
+sha256sums=('65f02cd4c926e1b4419edc429660bd3848dcfcbdd914b4c4dbb44a189d52f872')
+build() {
+ bsdtar -xf "${srcdir}/data."*
+ sed "s|/usr/bin/${_pkgname}|${pkgname%-bin}|g" -i "${srcdir}/usr/share/applications/${_appname}.desktop"
+}
package(){
- # Extract package data
- tar xf data.tar.xz -C "${srcdir}"
- cd "${srcdir}"
-
- install -Dm0755 usr/bin/helio "$pkgdir"/usr/bin/helio
- install -Dm0755 usr/share/applications/Helio.desktop "$pkgdir"/usr/share/applications/helio.desktop
- for i in 16x16 32x32 48x48 128x128 256x256; do
- install -Dm644 usr/share/icons/hicolor/"$i"/apps/helio-workstation.png \
- "$pkgdir"/usr/share/icons/hicolor/"$i"/apps/helio-workstation.png
+ install -Dm755 "${srcdir}/usr/bin/${_pkgname}" "${pkgdir}/usr/bin/${pkgname%-bin}"
+ install -Dm755 "${srcdir}/usr/share/applications/${_appname}.desktop" "${pkgdir}/usr/share/applications/${pkgname%-bin}.desktop"
+ for _icons in 16x16 32x32 48x48 128x128 256x256; do
+ install -Dm644 "${srcdir}/usr/share/icons/hicolor/${_icons}/apps/${pkgname%-bin}.png" \
+ -t "${pkgdir}/usr/share/icons/hicolor/${_icons}/apps"
done
-}
+} \ No newline at end of file