diff options
author | Robin Jadoul | 2024-08-23 15:52:56 +0200 |
---|---|---|
committer | Robin Jadoul | 2024-08-23 15:52:56 +0200 |
commit | 50dd53d37758a623350cbf991a1d34602d0b5118 (patch) | |
tree | 6897be191b2c7d0c5cff5fdd116f641af43a7110 | |
parent | ce65fd779f05e6b78a4f53f32bd0026123627cf2 (diff) | |
download | aur-helix-git.tar.gz |
remove explicit toolchain env var in favor of the existing rust-toolchain.toml
-rw-r--r-- | PKGBUILD | 3 |
1 files changed, 0 insertions, 3 deletions
@@ -35,21 +35,18 @@ EOF chmod +x "$_bin" cd "${_pkgname}" - export RUSTUP_TOOLCHAIN=stable export CARGO_TARGET_DIR=target cargo fetch --locked --target "$(rustc -vV | sed -n 's/host: //p')" } build() { cd "${_pkgname}" - export RUSTUP_TOOLCHAIN=stable export CARGO_TARGET_DIR=target cargo build --locked --profile opt } check() { cd "${_pkgname}" - export RUSTUP_TOOLCHAIN=stable export CARGO_TARGET_DIR=target cargo test --workspace --locked export RUSTFLAGS="${RUSTFLAGS} --cfg tokio_unstable" |