summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristopher Arndt2016-07-23 14:16:34 +0200
committerChristopher Arndt2016-07-23 14:16:34 +0200
commit6a237f706b71d68ef20c93d39c21523aa79c481b (patch)
tree89c3acf752da163dcc22f4d8d57de89b6e4c2868
parent14218d5208a4b1a4c32f91d89eba140f44cca356 (diff)
downloadaur-6a237f706b71d68ef20c93d39c21523aa79c481b.tar.gz
Fix compilation; use steinberg-vst36 AUR package
Signed-off-by: Christopher Arndt <chris@chrisarndt.de>
-rw-r--r--.SRCINFO7
-rw-r--r--ChangeLog7
-rw-r--r--PKGBUILD32
3 files changed, 34 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 21cd7a1fcdb5..3000cb355e16 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,8 @@
+# Generated by mksrcinfo v8
+# Sat Jul 23 12:15:35 UTC 2016
pkgbase = helm-git
pkgdesc = a cross-platform, polyphonic synthesizer LV2 and VST plugin
- pkgver = 0.5.0.r1105.ad798d4
+ pkgver = 0.8.5.r1458.6dbcd64
pkgrel = 1
url = http://tytel.org/helm/
changelog = ChangeLog
@@ -10,6 +12,7 @@ pkgbase = helm-git
groups = vst-plugins
license = GPL
makedepends = git
+ makedepends = steinberg-vst36
depends = alsa-lib
depends = freetype2
depends = mesa
@@ -17,9 +20,7 @@ pkgbase = helm-git
provides = helm
conflicts = helm
source = helm::git+https://github.com/mtytel/helm.git
- source = http://www.steinberg.net/sdk_downloads/vstsdk360_22_11_2013_build_100.zip
md5sums = SKIP
- md5sums = 1ac422ebb4aa2e86061278412c347b55
pkgname = helm-git
diff --git a/ChangeLog b/ChangeLog
index 803d4b1b1b34..77c55fdeebe1 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,6 +1,11 @@
+2016-07-22 Christopher Arndt <aur -at- chrisarndt -dot- de>
+ * 0.8.5.r1458.6dbcd64-1:
+ use steinberg-vst36 AUR package instead of including VST3 SDK in sources
+ Fix compilations error relating to lround function
+
2015-07-12 Christopher Arndt <aur -at- chrisarndt -dot- de>
* 0.3.3.r958.0741c59-2:
add VST3 SDK to sources, since it can be downloaded from Steinberg's
website now without login
- removed 'unzip' from dependencies accordingly \ No newline at end of file
+ removed 'unzip' from dependencies accordingly
diff --git a/PKGBUILD b/PKGBUILD
index d24977430f94..44418da92f70 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
_pkgname=helm
pkgname="${_pkgname}-git"
-pkgver=0.5.0.r1105.ad798d4
+pkgver=0.8.5.r1458.6dbcd64
pkgrel=1
pkgdesc="a cross-platform, polyphonic synthesizer LV2 and VST plugin"
arch=('i686' 'x86_64')
@@ -10,19 +10,33 @@ url="http://tytel.org/helm/"
license=('GPL')
groups=('lv2-plugins' 'vst-plugins')
depends=('alsa-lib' 'freetype2' 'mesa' 'lv2')
-makedepends=('git')
+makedepends=('git' 'steinberg-vst36')
provides=("${_pkgname}")
conflicts=("${_pkgname}")
-source=("${_pkgname}::git+https://github.com/mtytel/helm.git"
- 'http://www.steinberg.net/sdk_downloads/vstsdk360_22_11_2013_build_100.zip')
-md5sums=('SKIP'
- '1ac422ebb4aa2e86061278412c347b55')
+source=("${_pkgname}::git+https://github.com/mtytel/helm.git")
+md5sums=('SKIP')
changelog=ChangeLog
prepare() {
- cd "$srcdir/${_pkgname}/builds/linux/VST"
- sed -i -e "s|-I ~/srcs/VST3\\\\ SDK|-I $srcdir/VST3\\\\ SDK|" Makefile
+ cd "$srcdir/${_pkgname}"
+
+ msg2 "Fixing Makefiles..."
+ sed -i -e "s|-I ~/srcs/VST3\\\\ SDK||" \
+ builds/linux/VST/Makefile
+
+ for build in standalone/builds/linux builds/linux/VST builds/linux/LV2; do
+ sed -i -e 's|JUCE_INCLUDE_PNGLIB_CODE=0|JUCE_INCLUDE_PNGLIB_CODE=1|g' \
+ "$build/Makefile"
+ done
+
+ msg2 "Fixing VST3 SDK include paths in JUCE sources..."
+ for file in \
+ JUCE/extras/Introjucer/Source/Utility/jucer_StoredSettings.cpp \
+ JUCE/modules/juce_audio_plugin_client/VST/juce_VST_Wrapper.cpp \
+ JUCE/modules/juce_audio_processors/format_types/juce_VST3Headers.h; do
+ sed -i -e 's|public.sdk/source/vst2.x|vst36|g' "$file"
+ done
}
pkgver() {
@@ -36,12 +50,14 @@ pkgver() {
build() {
cd "${srcdir}/${_pkgname}"
+ CXXFLAGS="${CXXFLAGS} -DHAVE_LROUND"
make PREFIX="/usr" all vst
}
package() {
cd "${srcdir}/${_pkgname}"
+ CXXFLAGS="${CXXFLAGS} -DHAVE_LROUND"
make DESTDIR="$pkgdir" install
install -D builds/linux/VST/build/helm.so "$pkgdir/usr/lib/vst/helm.so"
}