summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFrank Siegert2020-04-16 17:33:42 +0200
committerFrank Siegert2020-04-16 17:33:48 +0200
commit8159c759a4b5d6cbf51cd69abd83633018431893 (patch)
tree294081e99c29680ce4434a8f56d859e17d0570fe
parent4a300dd15a110e02ff988f563681e63f146cefb6 (diff)
downloadaur-hepmc3.tar.gz
Update to 3.2.1-3: add patch for crash in cross section class
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD14
2 files changed, 14 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 58c6c8f18518..e3ec37669ff3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = hepmc3
pkgdesc = A particle physics package for storing collision events from Monte Carlo generators.
pkgver = 3.2.1
- pkgrel = 2
+ pkgrel = 3
url = http://hepmc.web.cern.ch/hepmc/
arch = x86_64
arch = i686
@@ -10,8 +10,10 @@ pkgbase = hepmc3
optdepends = root: ROOT I/O support
source = https://hepmc.web.cern.ch/hepmc/releases/HepMC3-3.2.1.tar.gz
source = https://gitlab.cern.ch/hepmc/HepMC3/-/commit/ba38f14d8f56c16cc4105d98f6d4540c928c6150.diff
+ source = https://gitlab.cern.ch/hepmc/HepMC3/-/commit/090f0ab74fe7b19e96d0ce9f8fb7fe11a7046fec.diff
md5sums = 8cc6cc4f13fdf8be9ed677924daea250
md5sums = d8635566838595ff7d5884f0294bb960
+ md5sums = 0d4842ad423c1e558cb888711902b275
pkgname = hepmc3
diff --git a/PKGBUILD b/PKGBUILD
index 810887bce4e8..341dc3b2ee74 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,29 @@
# Maintainer: Frank Siegert <frank.siegert@googlemail.com>
pkgname=hepmc3
pkgver=3.2.1
-pkgrel=2
+pkgrel=3
pkgdesc="A particle physics package for storing collision events from Monte Carlo generators."
arch=('x86_64' 'i686')
url="http://hepmc.web.cern.ch/hepmc/"
license=('GPL3')
makedepends=('cmake')
optdepends=('root: ROOT I/O support')
-source=("https://hepmc.web.cern.ch/hepmc/releases/HepMC3-${pkgver}.tar.gz" "https://gitlab.cern.ch/hepmc/HepMC3/-/commit/ba38f14d8f56c16cc4105d98f6d4540c928c6150.diff")
+source=("https://hepmc.web.cern.ch/hepmc/releases/HepMC3-${pkgver}.tar.gz"
+ "https://gitlab.cern.ch/hepmc/HepMC3/-/commit/ba38f14d8f56c16cc4105d98f6d4540c928c6150.diff"
+ "https://gitlab.cern.ch/hepmc/HepMC3/-/commit/090f0ab74fe7b19e96d0ce9f8fb7fe11a7046fec.diff"
+ )
noextract=()
md5sums=('8cc6cc4f13fdf8be9ed677924daea250'
- 'd8635566838595ff7d5884f0294bb960')
+ 'd8635566838595ff7d5884f0294bb960'
+ '0d4842ad423c1e558cb888711902b275')
build() {
cd "$srcdir/HepMC3-$pkgver"
+ # bugfix for compilation with gcc>=9.2.1
patch -p1 < ../ba38f14d8f56c16cc4105d98f6d4540c928c6150.diff
+ # bugfix for crash in cross section class
+ patch -p1 < ../090f0ab74fe7b19e96d0ce9f8fb7fe11a7046fec.diff
+
mkdir -p build
cd build
cmake ../ -DROOT_DIR=/usr -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_INSTALL_LIBDIR=lib