summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMedzikUser2022-02-28 20:38:26 +0100
committerMedzikUser2022-02-28 20:38:26 +0100
commit74f33114f44c395a70d84682e16d4afcb8ec6f94 (patch)
tree3a66808e93c04d6bbab4b69196d15a9efe1e9f00
parentd2f1a2fb8611c03e93cb614d07a07a1436bffdb7 (diff)
downloadaur-hex-rs.tar.gz
update to v0.1.2
-rw-r--r--.SRCINFO10
-rw-r--r--LICENSE21
-rw-r--r--PKGBUILD39
3 files changed, 26 insertions, 44 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5a3c2634d46f..8822b6214eff 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,11 @@
pkgbase = hex-rs
- pkgdesc = A simple command line hex viewer written in Rust.
- pkgver = 0.1.0
+ pkgdesc = A simple command line hex viewer written in Rust
+ pkgver = 0.1.2
pkgrel = 1
url = https://github.com/fffzlfk/hex-rs
arch = x86_64
license = MIT
- provides = hex-rs
- conflicts = hex-rs
- source = https://github.com/fffzlfk/hex-rs/releases/download/v0.1.0/hex-rs-0.1.0-x86_64.tar.gz
- sha256sums = cea99c751469c99d55fcdaf589f25ad035cb670e1d043fa37a5aaa1234066fde
+ source = hex-rs-0.1.2.tar.gz::https://github.com/fffzlfk/hex-rs/archive/v0.1.2.tar.gz
+ sha256sums = SKIP
pkgname = hex-rs
diff --git a/LICENSE b/LICENSE
deleted file mode 100644
index 16a45b8e36d2..000000000000
--- a/LICENSE
+++ /dev/null
@@ -1,21 +0,0 @@
-MIT License
-
-Copyright (c) 2022 fffzlfk
-
-Permission is hereby granted, free of charge, to any person obtaining a copy
-of this software and associated documentation files (the "Software"), to deal
-in the Software without restriction, including without limitation the rights
-to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
-copies of the Software, and to permit persons to whom the Software is
-furnished to do so, subject to the following conditions:
-
-The above copyright notice and this permission notice shall be included in all
-copies or substantial portions of the Software.
-
-THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
-IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
-FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
-AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
-LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
-OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
-SOFTWARE. \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
index 943601fcd2ae..6e479a3793fe 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,27 @@
-# Maintainer: fffzlfk <fffzlfk@qq.com>
-#
-# This PKGBUILD was generated by `cargo aur`: https://crates.io/crates/cargo-aur
+# Maintainer: MedzikUser <nivua1fn@duck.com>
+_repo='fffzlfk/hex-rs'
+_ver=v0.1.2
+_auto_update=true
-# Maintainer: fffzlfk <fffzlfk@qq.com>
-
-pkgname=hex-rs
-pkgver=0.1.0
+pkgname='hex-rs'
+pkgver=0.1.2
pkgrel=1
-pkgdesc="A simple command line hex viewer written in Rust."
-url="https://github.com/fffzlfk/hex-rs"
-license=("MIT")
-arch=("x86_64")
-provides=("hex-rs")
-conflicts=("hex-rs")
-source=("https://github.com/fffzlfk/hex-rs/releases/download/v$pkgver/hex-rs-$pkgver-x86_64.tar.gz")
-sha256sums=("cea99c751469c99d55fcdaf589f25ad035cb670e1d043fa37a5aaa1234066fde")
+pkgdesc='A simple command line hex viewer written in Rust'
+arch=('x86_64')
+url="https://github.com/${_repo}"
+license=('MIT')
+
+source=("$pkgname-$pkgver.tar.gz::$url/archive/${_ver}.tar.gz")
+sha256sums=('SKIP')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ cargo build --release
+}
package() {
- install -Dm755 hex-rs -t "$pkgdir/usr/bin"
- install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ cd "$srcdir/$pkgname-$pkgver"
+
+ install -Dm 755 "target/release/$pkgname" "$pkgdir/usr/bin/$pkgname"
+ install -Dm 644 "LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}