summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarsten Teibes2021-12-31 02:00:51 +0100
committerCarsten Teibes2021-12-31 02:00:51 +0100
commit10c9bfa40f4be473ac01c9e76d07673cf6384ca1 (patch)
treedfd7900c4ed3a3a83ca73fd391a23169e2d6d346
parent6c6e07107d58ee938b9a941d8bfe2d1ddbd73506 (diff)
downloadaur-hexxagon.tar.gz
[fix] building
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD13
-rw-r--r--hexxagon-1.0.2-glibc-2.31.patch11
3 files changed, 25 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a6dbe540b76a..60985ea5eb20 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,19 @@
pkgbase = hexxagon
pkgdesc = A clone of the old DOS game Hexxagon, with enhanced features and strong AI
pkgver = 1.0.2
- pkgrel = 2
+ pkgrel = 3
url = http://www.nesqi.se
arch = i686
arch = x86_64
license = GPL
depends = gtkmm
source = http://nesqi.se/download/hexxagon-1.0.2.tar.bz2
+ source = hexxagon-1.0.2-glibc-2.31.patch
source = hexxagon.desktop
source = hexxagon.png
sha256sums = 49b13516822fd32a9c58d62735b841a6e47e1714273e03ad20d8a9343a7623cc
+ sha256sums = e2564d479a5a3c614c37f043db17b27201f1fd054c1f86028c667eebf25d2926
sha256sums = 673fb40dbfeb96f2594f06f1b105afd23686472d5ef380e8b07d1a0f30b1e822
sha256sums = 0405a14380a379e6502b663d9db77be8471b84aa838fe3f645e25bdbd03c78c7
pkgname = hexxagon
-
diff --git a/PKGBUILD b/PKGBUILD
index c3e58ca90144..feec32ec3895 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,22 +4,31 @@
pkgname=hexxagon
pkgver=1.0.2
-pkgrel=2
+pkgrel=3
pkgdesc='A clone of the old DOS game Hexxagon, with enhanced features and strong AI'
arch=('i686' 'x86_64')
license=('GPL')
url='http://www.nesqi.se'
depends=('gtkmm')
-source=("http://nesqi.se/download/hexxagon-$pkgver.tar.bz2"
+source=("http://nesqi.se/download/$pkgname-$pkgver.tar.bz2"
+ "$pkgname-$pkgver-glibc-2.31.patch"
"$pkgname.desktop"
"$pkgname.png")
sha256sums=('49b13516822fd32a9c58d62735b841a6e47e1714273e03ad20d8a9343a7623cc'
+ 'e2564d479a5a3c614c37f043db17b27201f1fd054c1f86028c667eebf25d2926'
'673fb40dbfeb96f2594f06f1b105afd23686472d5ef380e8b07d1a0f30b1e822'
'0405a14380a379e6502b663d9db77be8471b84aa838fe3f645e25bdbd03c78c7')
+prepare() {
+ # remove timezone redeclarations
+ patch -d $pkgname-$pkgver -Np1 < $pkgname-$pkgver-glibc-2.31.patch
+}
+
build() {
cd $pkgname-$pkgver
+ # disable glib deprecation warnings
+ export CPPFLAGS="$CPPFLAGS -DGLIB_DISABLE_DEPRECATION_WARNINGS"
./configure --prefix=/usr
make
}
diff --git a/hexxagon-1.0.2-glibc-2.31.patch b/hexxagon-1.0.2-glibc-2.31.patch
new file mode 100644
index 000000000000..037228067c90
--- /dev/null
+++ b/hexxagon-1.0.2-glibc-2.31.patch
@@ -0,0 +1,11 @@
+glibc-2.31 removed timezone support and it conflicts with the re-declaration.
+https://bugs.gentoo.org/710712
+--- a/src/gui/microtime.h
++++ b/src/gui/microtime.h
+@@ -24,6 +24,4 @@
+ #include <time.h>
+
+-int gettimeofday(struct timeval *tv, struct timezone *tz);
+-int settimeofday(const struct timeval *tv , const struct timezone *tz);
+
+ class MicroTime