summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAntonio Orefice2022-09-05 12:15:25 +0200
committerAntonio Orefice2022-09-05 12:15:25 +0200
commit27f731a17df44debe87a5ba4271917196086c9c3 (patch)
treed7f9ca19fa327f931505ef10382c9184911ac467
parent3e2135788bf5c3988e2618e8acbf109928c799ea (diff)
downloadaur-higgins-git.tar.gz
Proper git package, thanks SanskritFritz
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD46
2 files changed, 29 insertions, 25 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c2a78b33b1bf..f4c4cfeb488c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Fri Apr 1 09:39:59 UTC 2022
+# Mon Sep 5 10:15:06 UTC 2022
pkgbase = higgins-git
- pkgdesc = Gambas apps launcher
- pkgver = 20210727
+ pkgdesc = Yet another application launcher, search for things, do calculations or whatever you want through external plugins
+ pkgver = r441.a4d00dc
pkgrel = 1
url = https://github.com/kokoko3k/higgins
arch = any
@@ -27,6 +27,8 @@ pkgbase = higgins-git
depends = gambas3-gb-image-effect
depends = gambas3-gb-util-web
depends = xbindkeys
+ source = git+https://github.com/kokoko3k/higgins.git
+ md5sums = SKIP
pkgname = higgins-git
diff --git a/PKGBUILD b/PKGBUILD
index 9e1a941809d5..97c7c4bbfee1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,10 @@
# Maintainer : Antonio Orefice <xt7player@gmail.com>
+# Contributor: SanskritFritz (gmail)
pkgname=higgins-git
-pkgver=20210727
+pkgver=r441.a4d00dc
pkgrel=1
-pkgdesc="Gambas apps launcher"
+pkgdesc="Yet another application launcher, search for things, do calculations or whatever you want through external plugins"
arch=('any')
license=('GPL')
url="https://github.com/kokoko3k/higgins"
@@ -11,33 +12,35 @@ url="https://github.com/kokoko3k/higgins"
makedepends=('gambas3-dev-tools' 'git')
depends=(
- 'schedtool'
+ 'schedtool'
'gambas3-runtime>=3.1.1'
'gambas3-gb-form>=3.1.1'
'gambas3-gb-qt5>=3.1.1'
'gambas3-gb-desktop>=3.1.1'
'gambas3-gb-image>=3.1.1'
'gambas3-gb-settings>=3.1.1'
- 'gambas3-gb-form-stock>=3.1.1'
- 'gambas3-gb-desktop-x11'
- 'gambas3-gb-web'
- 'gambas3-gb-net'
- 'gambas3-gb-util'
- 'gambas3-gb-dbus'
- 'gambas3-gb-image'
- 'gambas3-gb-args'
- 'gambas3-gb-image-effect'
- 'gambas3-gb-util-web'
- 'xbindkeys')
-
-_gitroot="https://github.com/kokoko3k/higgins.git"
+ 'gambas3-gb-form-stock>=3.1.1'
+ 'gambas3-gb-desktop-x11'
+ 'gambas3-gb-web'
+ 'gambas3-gb-net'
+ 'gambas3-gb-util'
+ 'gambas3-gb-dbus'
+ 'gambas3-gb-image'
+ 'gambas3-gb-args'
+ 'gambas3-gb-image-effect'
+ 'gambas3-gb-util-web'
+ 'xbindkeys')
+
+source=("git+https://github.com/kokoko3k/higgins.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "higgins"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
build() {
- cd $srcdir
-
- git clone $_gitroot || return 1
-
- cd $srcdir/higgins
+ cd higgins
gbc3 -e -a -g -t -f public-module -f public-control || gbc3 -e -a -g -t -p -m
gba3
@@ -51,4 +54,3 @@ package() {
install -D appicon.png ${pkgdir}/usr/share/pixmaps/higgins.png
install -D higgins.desktop ${pkgdir}/usr/share/applications/higgins.desktop
}
-