summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGuillaume Horel2020-10-08 16:56:43 -0400
committerGuillaume Horel2020-10-08 16:56:43 -0400
commitc3ab879a69a0dec86122ea38373b2c073314bdc3 (patch)
tree8189fe5f7dd012ad0489487e9d61445cd45633b0
parent6617b4ba5e602989622a98b5f304db71a5efc903 (diff)
downloadaur-highwayhash.tar.gz
add test, fix compilation
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD9
2 files changed, 8 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 11e66e050004..751d0a6be05e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = highwayhash
pkgdesc = Fast strong hash functions: SipHash/HighwayHash
- pkgver = 20200914.ead8f55
+ pkgver = 20200922.bdd572d
pkgrel = 1
url = https://github.com/google/highwayhash
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index 30f4c24aa4e3..103c952320dc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Guillaume Horel <guillaume.horel@gmail.com>
pkgname='highwayhash'
-pkgver=20200914.ead8f55
+pkgver=20200922.bdd572d
pkgrel=1
pkgdesc="Fast strong hash functions: SipHash/HighwayHash"
url="https://github.com/google/highwayhash"
@@ -19,7 +19,7 @@ pkgver() {
build() {
cd "${pkgname}"
- make
+ make CXXFLAGS="${CXXFLAGS} -fno-strict-aliasing"
}
package() {
@@ -28,3 +28,8 @@ package() {
install -d "$pkgdir/usr/share/man/man3"
gzip -c highwayhash.3 > "$pkgdir/usr/share/man/man3/highwayhash.3.gz"
}
+
+check() {
+ cd "${pkgname}"
+ bin/highwayhash_test
+}