summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohn K. Luebs2017-04-25 20:24:44 -0400
committerJohn K. Luebs2017-04-25 20:24:44 -0400
commite0cc1567f43a1e74160b18f3b2dd26c6ba1514e0 (patch)
tree3d22510458b3829aec1823efdc40f8da4901b907
parent9d0fccf7366da7842abb6a306747d81c604e465f (diff)
downloadaur-e0cc1567f43a1e74160b18f3b2dd26c6ba1514e0.tar.gz
Fix openssl compatibility issue: force to 1.0
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD9
2 files changed, 10 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c78e7f07cb17..2d1167206788 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Fri Jan 13 23:20:24 UTC 2017
+# Wed Apr 26 00:24:15 UTC 2017
pkgbase = hipchat
pkgdesc = Persistent group chat using XMPP
pkgver = 4.29.4.1662
- pkgrel = 1
+ pkgrel = 2
url = https://www.hipchat.com/linux
arch = x86_64
license = custom
@@ -21,6 +21,7 @@ pkgbase = hipchat
depends = libpulse
depends = xcb-util-keysyms
depends = nss
+ depends = openssl-1.0
source = https://atlassian.artifactoryonline.com/atlassian/hipchat-apt-client/pool/HipChat4-4.29.4.1662-Linux.deb
source = license.html
sha1sums = 9a92f389b24bea827fae76d3310c360023d4a214
diff --git a/PKGBUILD b/PKGBUILD
index 6554c3165fbc..8f53067a5bd9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,14 +7,14 @@
pkgname=hipchat
pkgver=4.29.4.1662
-pkgrel=1
+pkgrel=2
pkgdesc="Persistent group chat using XMPP"
arch=('x86_64')
url="https://www.hipchat.com/linux"
license=('custom')
depends=('fontconfig' 'libgl' 'libltdl' 'libxslt' 'hicolor-icon-theme'
'libxcomposite' 'libxcursor' 'libxkbcommon' 'libxrandr' 'libxslt' 'libxss'
- 'libpulse' 'xcb-util-keysyms' 'nss')
+ 'libpulse' 'xcb-util-keysyms' 'nss' 'openssl-1.0')
source=("https://atlassian.artifactoryonline.com/atlassian/hipchat-apt-client/pool/HipChat4-${pkgver}-Linux.deb" "license.html")
sha1sums=('9a92f389b24bea827fae76d3310c360023d4a214'
'd57436db297ab4313a5964bba05060e2c7e93e70')
@@ -32,4 +32,9 @@ package() {
cp -R "${srcdir}/${pkgname}-${pkgver}"/{opt,usr} "${pkgdir}"
mkdir -p "${pkgdir}/usr/bin"
ln -nsf "/opt/HipChat4/bin/HipChat4" "${pkgdir}/usr/bin/hipchat4"
+
+ ln -nsf "/usr/lib/libssl.so.1.0.0" "${pkgdir}/opt/HipChat4/lib/"
+ ln -nsf libssl.so.1.0.0 "${pkgdir}/opt/HipChat4/lib/libssl.so"
+ ln -nsf "/usr/lib/libcrypto.so.1.0.0" "${pkgdir}/opt/HipChat4/lib/"
+ ln -nsf libcrypto.so.1.0.0 "${pkgdir}/opt/HipChat4/lib/libcrypto.so"
}