summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHsiu-Ming Chang2018-02-15 20:25:46 +0800
committerHsiu-Ming Chang2018-02-15 20:25:46 +0800
commit1d214848ba81bf6189788200a776c5aa9840826b (patch)
tree2f908d20694ecc877d9f58f6e19cde8be8d5b320
parentf0f007af6fb30d8d78e90f3c73b5e326a3c8ec87 (diff)
downloadaur-1d214848ba81bf6189788200a776c5aa9840826b.tar.gz
Update to version 2.5
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD15
2 files changed, 12 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0a01ce03bd7c..e764362d9eba 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
pkgbase = hmtimer
pkgdesc = graphical shutdown timer
- pkgver = 2.4.2
- pkgrel = 2
- url = https://sites.google.com/site/hsiumingstimer/
+ pkgver = 2.5
+ pkgrel = 1
+ url = https://hsiumingstimer.sourceforge.io/
install = hmtimer.install
arch = i686
arch = x86_64
@@ -10,8 +10,8 @@ pkgbase = hmtimer
depends = qt5-base
depends = qt5-multimedia
depends = hicolor-icon-theme
- source = https://sourceforge.net/projects/hsiumingstimer/files/hmtimer-2.4.2/hmtimer-2.4.2-src.tar.bz2
- md5sums = 42b3d0f833d1002f7c526158e97b9a50
+ source = https://sourceforge.net/projects/hsiumingstimer/files/hmtimer-2.5/hmtimer-2.5-src.tar.bz2
+ md5sums = 9e5b4460d28ae9b12cb0e5a11d8c8579
pkgname = hmtimer
diff --git a/PKGBUILD b/PKGBUILD
index 3dcddff78a3d..b4baa1d6846b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,10 +1,10 @@
# Maintainer: Hsiu-Ming Chang <cges30901 at gmail dot com>
pkgname=hmtimer
-pkgver=2.4.2
-pkgrel=2
+pkgver=2.5
+pkgrel=1
pkgdesc="graphical shutdown timer"
arch=('i686' 'x86_64')
-url="https://sites.google.com/site/hsiumingstimer/"
+url="https://hsiumingstimer.sourceforge.io/"
license=('GPL3')
groups=()
depends=('qt5-base' 'qt5-multimedia' 'hicolor-icon-theme')
@@ -19,23 +19,22 @@ install="$pkgname.install"
changelog=
source=("https://sourceforge.net/projects/hsiumingstimer/files/hmtimer-$pkgver/hmtimer-$pkgver-src.tar.bz2")
noextract=()
-md5sums=('42b3d0f833d1002f7c526158e97b9a50')
+md5sums=('9e5b4460d28ae9b12cb0e5a11d8c8579')
build() {
cd "$pkgname-$pkgver"
qmake
make
+ gzip hmtimer.1
}
package() {
cd "$pkgname-$pkgver"
install -D -m0755 src/hmtimer $pkgdir/usr/bin/hmtimer
- install -D -m0644 src/language/hmtimer_zh_TW.qm $pkgdir/usr/share/hmtimer/hmtimer_zh_TW.qm
- install -D -m0644 src/language/hmtimer_ar.qm $pkgdir/usr/share/hmtimer/hmtimer_ar.qm
- install -D -m0644 src/language/hmtimer_ru.qm $pkgdir/usr/share/hmtimer/hmtimer_ru.qm
- install -D -m0644 src/language/hmtimer_be.qm $pkgdir/usr/share/hmtimer/hmtimer_be.qm
+ install -D -m0644 -t $pkgdir/usr/share/hmtimer src/language/hmtimer_*.qm
install -D -m0644 hmtimer.desktop $pkgdir/usr/share/applications/hmtimer.desktop
install -D -m0644 src/hmtimer.png $pkgdir/usr/share/icons/hicolor/128x128/apps/hmtimer.png
install -D -m0644 src/hmtimer48.png $pkgdir/usr/share/icons/hicolor/48x48/apps/hmtimer.png
+ install -D -m0644 hmtimer.1.gz $pkgdir/usr/share/man/man1/hmtimer.1.gz
}