summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoretckeeper2022-07-09 11:54:07 +0200
committeretckeeper2022-07-09 11:54:07 +0200
commit384b877a222236213b66a70238bb3c82006a2600 (patch)
tree1dce00e5c3e7242ccdbb5a59dc74e3a84a74e656
parent855a2bfe02f86209cf11eb43f8f66e55d2740ba2 (diff)
downloadaur-384b877a222236213b66a70238bb3c82006a2600.tar.gz
added temp workaround for pip installation in home assistant being broken
ref: https://github.com/home-assistant/core/issues/74405
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD4
-rw-r--r--hass-update.service3
3 files changed, 7 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f34d5339c340..4ea1aa15b030 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = home-assistant-service-pip
pkgdesc = Self installing package of Home Assistant using pip
- pkgver = 3
- pkgrel = 2
+ pkgver = 4
+ pkgrel = 1
url = https://home-assistant.io/
install = hass.install
arch = any
diff --git a/PKGBUILD b/PKGBUILD
index f62d8973c4f4..4b1bdd42ac52 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
pkgname=home-assistant-service-pip
_serviceName=hass
pkgdesc='Self installing package of Home Assistant using pip'
-pkgver=3
-pkgrel=3
+pkgver=4
+pkgrel=1
arch=('any')
url='https://home-assistant.io/'
license=(APACHE)
diff --git a/hass-update.service b/hass-update.service
index 33bbfe75fca4..6392f79f2705 100644
--- a/hass-update.service
+++ b/hass-update.service
@@ -15,6 +15,9 @@ Type=oneshot
# upgrade home assistant and all its necessary libs
ExecStart=pip install --no-warn-script-location --user --upgrade homeassistant
+# temp workaround for https://github.com/home-assistant/core/issues/74405
+ExecStart = sh -c "find $(python -c 'import site; print(site.getusersitepackages())') -wholename '*/homeassistant/util/package.py' -exec sed -i '/--prefix=/d' {} \; "
+
# delete old python version libraries in the venv
ExecStart=sh -c '\
find \