summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLubosz Sarnecki2016-11-02 15:54:09 +0100
committerLubosz Sarnecki2016-11-02 15:54:09 +0100
commit9f44b54d16c2437fb74cc3420c49ce7b6bc8c556 (patch)
tree4fd32896c831445dbe8087638c1f850836e942ba
downloadaur-9f44b54d16c2437fb74cc3420c49ce7b6bc8c556.tar.gz
initial commit.
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD21
2 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..93a2c8d51273
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+# Generated by mksrcinfo v8
+# Wed Nov 2 14:53:58 UTC 2016
+pkgbase = hotdoc
+ pkgdesc = The tastiest API documentation system.
+ pkgver = 0.8.1
+ pkgrel = 1
+ url = https://github.com/hotdoc/hotdoc
+ arch = i686
+ arch = x86_64
+ license = LGPLv2
+ depends = python2
+ depends = python2-sqlalchemy
+ depends = python2-schema
+ depends = python2-toposort
+ depends = python2-wheezy
+ depends = python2-pygraphviz
+ source = git+https://github.com/hotdoc/hotdoc.git#tag=0.8.1
+ md5sums = SKIP
+
+pkgname = hotdoc
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..51dc7dab8dab
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: Lubosz Sarnecki <lubosz@gmail.com>
+pkgname=hotdoc
+pkgver=0.8.1
+pkgrel=1
+pkgdesc="The tastiest API documentation system."
+arch=('i686' 'x86_64')
+url="https://github.com/hotdoc/hotdoc"
+license=('LGPLv2')
+depends=('python2' 'python2-sqlalchemy' 'python2-schema' 'python2-toposort' 'python2-wheezy' 'python2-pygraphviz')
+source=("git+https://github.com/hotdoc/hotdoc.git#tag=$pkgver")
+md5sums=('SKIP')
+
+build() {
+ cd hotdoc
+ python2 setup.py build
+}
+
+package() {
+ cd hotdoc
+ python2 setup.py install --root="$pkgdir" --optimize=1
+}