summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarsten Teibes2015-09-28 12:06:28 +0200
committerCarsten Teibes2015-09-28 12:06:28 +0200
commitaac3b4b9a113deef27f5c32216459032a957dc64 (patch)
tree346752eb176a99997fc9ea711a45af85394f82b2
parent9b5a7c5671e724ece2e0d2e0a654515257454a68 (diff)
downloadaur-hotline-miami-gog.tar.gz
[upd] 1.0.0.3→2.0.0.3
-rw-r--r--.SRCINFO31
-rw-r--r--PKGBUILD41
-rw-r--r--hotline-miami-gog.desktop8
3 files changed, 50 insertions, 30 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2bd3e5b40d7a..ae617df5a66c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,23 +1,32 @@
pkgbase = hotline-miami-gog
pkgdesc = 2D top-down action video game (gog.com version)
- pkgver = 1.0.0.2
+ pkgver = 2.0.0.3
pkgrel = 1
url = http://gog.com
arch = x86_64
arch = i686
license = custom: commercial
- depends = bash
- depends = libxrandr
- depends = fontconfig
- depends = libxi
- depends = glu
- depends = libvorbis
- depends = openal
- depends = nvidia-cg-toolkit
- source = gog://gog_hotline_miami_1.0.0.2.tar.gz
+ depends = sh
+ source = gog_hotline_miami_2.0.0.3.sh::gogdownloader://hotline_miami/installer_linux_en
source = hotline-miami-gog.sh
- sha256sums = 57d468be7bf6dd2b779519ba7883ac8ef03a8b88a346e31e5050b5537cb75f19
+ source = hotline-miami-gog.desktop
+ sha256sums = c8f181abcff33ee3c3ac5d7de8d40c477c83bb0dca974b0d523084d7c414e88f
sha256sums = a306f962134e56702e3211724b51e9a4d4abc99d55bb369f9c7a41d77e561bb7
+ sha256sums = 4080c3e3e129360152736c24e5019057d8dbbd08a62a3f6d77796ab6cd91e762
+ depends_x86_64 = lib32-libxrandr
+ depends_x86_64 = lib32-fontconfig
+ depends_x86_64 = lib32-libxi
+ depends_x86_64 = lib32-glu
+ depends_x86_64 = lib32-libvorbis
+ depends_x86_64 = lib32-openal
+ depends_x86_64 = lib32-nvidia-cg-toolkit
+ depends_i686 = libxrandr
+ depends_i686 = fontconfig
+ depends_i686 = libxi
+ depends_i686 = glu
+ depends_i686 = libvorbis
+ depends_i686 = openal
+ depends_i686 = nvidia-cg-toolkit
pkgname = hotline-miami-gog
diff --git a/PKGBUILD b/PKGBUILD
index d2e1d05c6ca6..55bda204e9dc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,29 +1,32 @@
# Maintainer: carstene1ns <arch carsten-teibes de> - http://git.io/ctPKG
pkgname=hotline-miami-gog
-pkgver=1.0.0.2
+pkgver=2.0.0.3
pkgrel=1
pkgdesc="2D top-down action video game (gog.com version)"
url="http://gog.com"
license=('custom: commercial')
arch=('x86_64' 'i686')
-depends=('bash' 'libxrandr' 'fontconfig' 'libxi' 'glu' 'libvorbis' 'openal' 'nvidia-cg-toolkit')
-if [ "$CARCH" == "x86_64" ]; then
- depends=('bash' 'lib32-libxrandr' 'lib32-fontconfig' 'lib32-libxi' 'lib32-glu' 'lib32-libvorbis' 'lib32-openal' 'lib32-nvidia-cg-toolkit')
-fi
-# You need to download the gog.com installer file manually or with lgogdownloader.
-# Or you can configure DLAGENTS in makepkg.conf to auto-search through a directory
-# containing gog.com downloads:
-# DLAGENTS=('gog::/usr/bin/find /path/to/downloads -name $(echo %u | cut -c 7-) -exec ln -s \{\} %o \; -quit')
-DLAGENTS+=('gog::/usr/bin/echo "Could not find \"$(echo %u | cut -c 7-)\". Manually download it to \"$(pwd)\", or set up a gog:// DLAGENT."; exit 1')
-source=("gog://gog_hotline_miami_$pkgver.tar.gz"
- "$pkgname.sh")
-sha256sums=('57d468be7bf6dd2b779519ba7883ac8ef03a8b88a346e31e5050b5537cb75f19'
- 'a306f962134e56702e3211724b51e9a4d4abc99d55bb369f9c7a41d77e561bb7')
+depends=('sh')
+depends_i686=('libxrandr' 'fontconfig' 'libxi' 'glu' 'libvorbis' 'openal' 'nvidia-cg-toolkit')
+depends_x86_64=('lib32-libxrandr' 'lib32-fontconfig' 'lib32-libxi' 'lib32-glu' 'lib32-libvorbis' 'lib32-openal' 'lib32-nvidia-cg-toolkit')
+source=("gog_hotline_miami_$pkgver.sh::gogdownloader://hotline_miami/installer_linux_en"
+ "$pkgname.sh"
+ "$pkgname.desktop")
+sha256sums=('c8f181abcff33ee3c3ac5d7de8d40c477c83bb0dca974b0d523084d7c414e88f'
+ 'a306f962134e56702e3211724b51e9a4d4abc99d55bb369f9c7a41d77e561bb7'
+ '4080c3e3e129360152736c24e5019057d8dbbd08a62a3f6d77796ab6cd91e762')
PKGEXT=".pkg.tar"
+# You need to download the gog.com installer file to this directory ($PWD),
+# either manually or with lgogdownloader. You can also configure DLAGENTS in
+# makepkg.conf to auto-download.
+#
+# The following is just a fallback to the above to notify the user:
+DLAGENTS+=('gogdownloader::/usr/bin/awk BEGIN{print"Please\ download\ the\ file\ \\""\ substr("%o",1,28)\ "\\"\ manually\\nor\ setup\ a\ gogdownloader://\ DLAGENT\ in\ makepkg.conf!\ Read\ this\ PKGBUILD\ for\ more\ information.";exit\ 1}')
+
package() {
- cd "Hotline Miami"
+ cd data/noarch
install -d "$pkgdir"/opt/hotline-miami
# data
install -m644 game/{*.ogg,*.wad} "$pkgdir"/opt/hotline-miami
@@ -34,8 +37,8 @@ package() {
install -m644 game/README support/support_notice.txt "$pkgdir"/usr/share/doc/$pkgname
install -m644 docs/"End User License Agreement.txt" "$pkgdir"/usr/share/licenses/$pkgname
# .desktop file and launcher
- install -Dm644 support/gog-hotline-miami-primary.desktop "$pkgdir"/usr/share/applications/hotline-miami.desktop
- install -Dm644 support/gog-hotline-miami.png "$pkgdir"/usr/share/pixmaps/hotline-miami.png
- sed "s|gog-||" -i "$pkgdir"/usr/share/applications/hotline-miami.desktop
- install -Dm755 ../$pkgname.sh "$pkgdir"/usr/bin/hotline-miami
+ install -Dm644 support/icon.png "$pkgdir"/usr/share/pixmaps/hotline-miami.png
+ cd "$srcdir"
+ install -Dm644 $pkgname.desktop "$pkgdir"/usr/share/applications/hotline-miami.desktop
+ install -Dm755 $pkgname.sh "$pkgdir"/usr/bin/hotline-miami
}
diff --git a/hotline-miami-gog.desktop b/hotline-miami-gog.desktop
new file mode 100644
index 000000000000..25f3270feae9
--- /dev/null
+++ b/hotline-miami-gog.desktop
@@ -0,0 +1,8 @@
+[Desktop Entry]
+Type=Application
+Terminal=false
+Name=Hotline Miami
+Icon=hotline-miami
+Exec=hotline-miami
+Categories=Game;ActionGame;
+StartupNotify=false