summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarco Rubin2024-04-25 22:35:46 +0200
committerMarco Rubin2024-04-25 22:35:46 +0200
commitfb1122af123882c8b8e7bb56a928ace4a6051297 (patch)
tree017be93db0842d9f96a9d9e219981074e0b764ed
parent02811e83577bf6eb4241b4cae60e9f353a8f4957 (diff)
downloadaur-hotspot.tar.gz
1.5.0
-rwxr-xr-x.SRCINFO13
-rwxr-xr-xPKGBUILD32
2 files changed, 11 insertions, 34 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 617ade8daffc..34f5f4b5d12c 100755
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = hotspot
pkgdesc = The Linux perf GUI for performance analysis
- pkgver = 20240412
+ pkgver = 1.5.0
pkgrel = 1
url = https://github.com/KDAB/hotspot
arch = x86_64
@@ -8,7 +8,6 @@ pkgbase = hotspot
makedepends = cmake>=3.16.0
makedepends = desktop-file-utils
makedepends = extra-cmake-modules
- makedepends = git
depends = elfutils
depends = kconfig
depends = kconfigwidgets
@@ -22,16 +21,12 @@ pkgbase = hotspot
depends = kparts
depends = libelf
depends = perf
- depends = qt6-base
+ depends = qt6-base>=6.4
depends = rustc-demangle>=0.1.18-2
depends = solid
depends = syntax-highlighting
depends = threadweaver
- source = git+https://github.com/KDAB/hotspot#commit=d274358cefa0aa989d760091dc30a2f8a8030560
- source = git+https://github.com/KDAB/perfparser.git
- source = git+https://github.com/koenpoppe/PrefixTickLabels
- b2sums = 55c9f16b657773e5eec8a0be8242de9b205298d22f2731df2209028ea74fbedc70e906b799595fc1a16e4676a993c7401b82b24bbd555c9af8249192a5dc6f24
- b2sums = SKIP
- b2sums = SKIP
+ source = https://github.com/KDAB/hotspot/releases/download/v1.5.0/hotspot-v1.5.0.tar.gz
+ b2sums = 930f256fbe94068145d9366c1c7d0a1a75fca955d70d1acd9d698a888c7249404a832e579883f1bf18268578a664e10fdbb870ef328b51d55e8d1b59cb830da4
pkgname = hotspot
diff --git a/PKGBUILD b/PKGBUILD
index 692591a82f6c..ab20ce621243 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,7 @@
# Contributor: Florian Lindner <florian.lindner@xgm.de>
pkgname=hotspot
-pkgver=20240412
-_commit=d274358cefa0aa989d760091dc30a2f8a8030560
+pkgver=1.5.0
pkgrel=1
pkgdesc="The Linux perf GUI for performance analysis"
arch=('x86_64')
@@ -24,41 +23,24 @@ depends=(
'libelf'
'perf'
# 'qcustomplot' # currently it doesn't build
- 'qt6-base'
+ 'qt6-base>=6.4'
'rustc-demangle>=0.1.18-2'
'solid'
'syntax-highlighting'
'threadweaver'
)
-makedepends=('cmake>=3.16.0' 'desktop-file-utils' 'extra-cmake-modules' 'git')
-source=("git+$url#commit=$_commit"
- "git+https://github.com/KDAB/perfparser.git"
- "git+https://github.com/koenpoppe/PrefixTickLabels")
-b2sums=('55c9f16b657773e5eec8a0be8242de9b205298d22f2731df2209028ea74fbedc70e906b799595fc1a16e4676a993c7401b82b24bbd555c9af8249192a5dc6f24'
- 'SKIP'
- 'SKIP')
-
-pkgver() {
- cd $pkgname
- git log -n1 --pretty='format:%cd' --date=format:'%Y%m%d' $_commit
-}
-
-prepare() {
- cd $pkgname
- git submodule init
- git config submodule.3rdparty/perfparser.url "$srcdir/perfparser"
- git config submodule.3rdparty/PrefixTickLabels.url "$srcdir/PrefixTickLabels"
- git -c protocol.file.allow=always submodule update
-}
+makedepends=('cmake>=3.16.0' 'desktop-file-utils' 'extra-cmake-modules')
+source=("$url/releases/download/v$pkgver/$pkgname-v$pkgver.tar.gz")
+b2sums=('930f256fbe94068145d9366c1c7d0a1a75fca955d70d1acd9d698a888c7249404a832e579883f1bf18268578a664e10fdbb870ef328b51d55e8d1b59cb830da4')
build() {
- cd $pkgname
+ cd $pkgname-v$pkgver
cmake -DBUILD_TESTING=off -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_PREFIX=/usr -DQT6_BUILD=on .
cmake --build .
}
package() {
- cd $pkgname
+ cd $pkgname-v$pkgver
DESTDIR="$pkgdir" cmake --install .
desktop-file-install com.kdab.hotspot.desktop --dir="$pkgdir/usr/share/applications/"
}