summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichał Wojdyła2022-07-19 07:34:52 +0200
committerMichał Wojdyła2022-07-19 07:34:52 +0200
commit1910221ca31fd82df8926c1379869fed90a20f2f (patch)
tree2a63a06ff8f185d871fa042af2d02619741839a1
parente02ecaf823bd8f4c310d2c2003ce9a77381be993 (diff)
downloadaur-howm-x11-git.tar.gz
fix build
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD7
2 files changed, 6 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 62c6272e5445..6f4ef5ff21d6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,3 @@
-# Generated by mksrcinfo v8
-# Fri Sep 15 20:03:58 UTC 2017
pkgbase = howm-x11-git
pkgdesc = A lightweight, tiling X11 window manager that mimics vi by offering operators, motions and modes.
pkgver = 0.5.1.81.g3e3d6ee
@@ -18,4 +16,3 @@ pkgbase = howm-x11-git
sha256sums = SKIP
pkgname = howm-x11-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 3f988371af89..5f40ef679f2f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -18,6 +18,11 @@ pkgver() {
git describe --tags | sed 's/-/./g'
}
+prepare() {
+ cd "$pkgname"
+ git cherry-pick -n 16a910d7862b9771bcd12cef7cd6388d9e5d0c54
+}
+
build() {
cd "$pkgname"
# https://github.com/HarveyHunt/howm/issues/68
@@ -26,7 +31,7 @@ build() {
package() {
cd "$pkgname"
- make DESTDIR="$pkgdir" install
+ make DESTDIR="$pkgdir"/ install
mkdir -p "$pkgdir"/usr/share/howm/examples
cp -a examples/* "$pkgdir"/usr/share/howm/examples/