summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorfelics2020-01-14 14:24:44 +0100
committerfelics2020-01-14 14:24:44 +0100
commit0ccdf0a805aa7568e78c7340e95252378d607024 (patch)
tree135520912eb69dad47788eb0c8c1276b4f636ab8
parent12165a298efeb918306b2869864a93ffca117961 (diff)
downloadaur-hplip-3.18.tar.gz
Added explicit python include to CFLAGS in order to fix `configure: error: cannot find python-devel support`-error with python 3.8.
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD16
2 files changed, 16 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fa21d8d67f39..6bd64658158a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = hplip-3.18
pkgdesc = HPLIP, fixed version 3.18.x (with supports for some printers which were removed in 3.19), and with patch for uncompressed scanning on LEDM-based peripherals.
pkgver = 3.18.12
- pkgrel = 1
+ pkgrel = 2
url = http://hplipopensource.com
arch = x86_64
license = GPL
diff --git a/PKGBUILD b/PKGBUILD
index c9bd1687da9d..0cb34a3968a5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,7 +10,7 @@ _pkgname=hplip
_pkgmainver=3.18
pkgname="${_pkgname}-${_pkgmainver}"
pkgver="${_pkgmainver}.12"
-pkgrel=1
+pkgrel=2
pkgdesc="HPLIP, fixed version 3.18.x (with supports for some printers which were removed in 3.19), and with patch for uncompressed scanning on LEDM-based peripherals."
arch=('x86_64')
url="http://hplipopensource.com"
@@ -88,6 +88,20 @@ prepare() {
}
build() {
+ # Need to explicitly add python include directory for python3.8, otherwise the following error is thrown by `./configure`:
+ # checking python3.8/Python.h usability... no
+ # checking python3.8/Python.h presence... no
+ # checking for python3.8/Python.h... no
+ # checking python3.8mu/Python.h usability... no
+ # checking python3.8mu/Python.h presence... no
+ # checking for python3.8mu/Python.h... no
+ # checking python3.8m/Python.h usability... no
+ # checking python3.8m/Python.h presence... no
+ # checking for python3.8m/Python.h... no
+ # configure: error: cannot find python-devel support
+ CFLAGS+=" $(python-config --includes)"
+ export CFLAGS
+
cd "${_pkgname}-${pkgver}"
./configure \
--prefix=/usr \