summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBenjamin Levy2020-02-04 01:10:25 -0500
committerBenjamin Levy2020-02-04 01:10:25 -0500
commita9dedb93fa2440ff8834062e5167bb4a2bebaeb2 (patch)
tree07aba70e87b587f2c77d0a943c4ef94e95062a53
downloadaur-hpmor-man-pages-git.tar.gz
Init
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD27
3 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..36003dea1545
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = hpmor-man-pages-git
+ pkgdesc = Harry Potter and the Methods of Rationality, Unix Man Page Edition
+ pkgver = r21.33a25ea
+ pkgrel = 1
+ url = https://github.com/io12/hpmor-man-pages
+ arch = any
+ license = unknown
+ makedepends = go-md2man
+ makedepends = pandoc
+ makedepends = python
+ provides = hpmor-man-pages
+ source = git+https://github.com/io12/hpmor-man-pages
+ md5sums = SKIP
+
+pkgname = hpmor-man-pages-git
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..5d037acc92f5
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+/hpmor-man-pages/
+*.pkg.tar.xz
+/pkg/
+/src/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5bb6dc5cd6c1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Benjamin Levy <blevy@protonmail.com>
+pkgname=hpmor-man-pages-git
+pkgver=r21.33a25ea
+pkgrel=1
+provides=('hpmor-man-pages')
+makedepends=('go-md2man' 'pandoc' 'python')
+arch=('any')
+pkgdesc="Harry Potter and the Methods of Rationality, Unix Man Page Edition"
+license=('unknown')
+url="https://github.com/io12/hpmor-man-pages"
+source=("git+https://github.com/io12/hpmor-man-pages")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/hpmor-man-pages"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "$srcdir/hpmor-man-pages"
+ make
+}
+
+package() {
+ cd "$srcdir/hpmor-man-pages"
+ make DESTDIR="$pkgdir" PREFIX=/usr install
+}